none
Updates to .NET Framework 4 fail RRS feed

  • Question

  • My Win7 system consistently refuses to install the (presumably) last six .NET framework 4 updates. I've tried selecting only one at a time to install, but each one fails. Likewise my attempt to install Visual Studio 2010 SP1 failed. The failure code is always 643, which seems to be a rather meaningless catchall. Other Win7 updates have been installing without incident. Looking at the log  C:\Win\MS.NET\Framework\v4.0.30319\ngen_service.log, the following text appears many times:  

    1>Warning: System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.Interop.MSProject, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

    I should also say that frequently, on bootup, I get a Win32 unhandled exception error for nprotect.exe. I can't tell if that's related to the update failures.

    If I can't resolve these failures I'm prepared to re-install .NET 4 from  fresh download. If so, do I need to uninstall the existing NET 4 first?

    Otherwise the system works well:  4MB RAM, plenty of disk space, a 3GHz Intel dual core CPU.

    Thanks for any help and words of wisdom you can offer.

     

     

     

    Tuesday, January 17, 2012 8:10 PM

Answers

All replies

  • Let's see if your current installation of .NET Framework 4.0 is OK.

    Run this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Post the first 20 lines and last 20 lines of the tool output here.

    If verification fails:

    Try removing .NET Framework 4.0 using Add/Remove...

    You should also use this tool to ensure all parts are gone:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Then, please follow this procedure:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    3. Run the standalone installer from step 1 As Administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    If verification succeeds:

    Your issue is not with the .NET Framework. You most likely have a Windows Update issue. For best assistance, post here:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update

     

    Tuesday, January 17, 2012 9:00 PM
  • Thanks pvdg42. You've given me a lot to work with, so it may take a while to try it all. I'll get back to you in due course with the results.
    Tuesday, January 17, 2012 9:50 PM
  • Hi Rabnub,

     

    Welcome to MSDN forum.

    I'm doing a follow up here. Have you problem fixed with pvdg42's solution?

     

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, January 25, 2012 8:17 AM
    Moderator
  • Since Rabnum seems to no longer be with us, may I take his place :)

    I have the same problem. I used the verify tool and all the versions of Net Framework verify as "succeeded", but all updates to Net Framework 4 fail with a "643" error code.

    All tests on my Windows update installation also pass, all other updates except these install fine. 

    What else could cause these particular updates to fail?

    Thanks in advance!

    Musky

    Tuesday, February 28, 2012 9:30 PM