The following forum(s) are migrating to a new home on Microsoft Q&A (Preview): Azure Active Directory!

Ask new questions on Microsoft Q&A (Preview).
Interact with existing posts until December 13, 2019, after which content will be closed to all new and existing posts.

Learn More

 none
Azure ADFS Setup - Error ""We cannot federate an azure AD domain while signed in to azure AD as a user in the same domain." RRS feed

  • Question

  • Hi Support,

    I've verified my domain in Azure AD as divar.com.au, created two VMs and installed Azure Active Directory connect.

    Server one named DC1 and server two is ADFS. I am running Azure AD connect on DC server and I am able to go forward until the section "Select the Azure AD domain to federate with your on-premises directory"

    My AD domain name is divar.com.au and Cert on ADFS server is adfs.divar.com.au

    Not sure what's causing the issue. I've tried with different Azure AD account with Global Administrator privilege and made no difference.

    Error message which I get is:

    "We cannot federate an azure AD domain while signed in to azure AD as a user in the same domain.Please choose a different domain to federated or rest"art this wizard and provide different Azure AD global administrator credentials

    Thank you,


    • Edited by Hanif Moha Tuesday, October 8, 2019 12:15 PM
    Tuesday, October 8, 2019 12:14 PM

All replies

  • Use your default admin credentials, as in the first GA you create, the one with the @tenant.onmicrosoft.com domain.
    Tuesday, October 8, 2019 5:28 PM
  • I used my @Gmail account to create Azure portal, I tried to use that account and I get this error:

    unable to validate crednetials. Only Azure user accounts synchronized from your on-premises directory are
    supported for administration. [accessing_ws_metadata_exchange_failed]

    When I use the admin account I get this error message

    please provide administrator credentials for xxxx.onmicrosoft.com -AAD

    • Edited by Hanif Moha Wednesday, October 9, 2019 11:24 AM
    Wednesday, October 9, 2019 10:52 AM