locked
No .Net framework v3.5 folder found in ..\Microsoft.NET\Framework RRS feed

  • Question

  • In my previous question i said i can't install dot net framework v3.5 in windows 7 i recieved answer there is built in, 

    i just opened  C:\Windows\Microsoft.NET\Framework

    there i can find others version like v1, v2 but i cant find v3.5

    i am using windows 7 ultimate 

    thanks


    • Edited by Liang Lee Thursday, March 7, 2013 5:20 AM
    Thursday, March 7, 2013 5:19 AM

Answers

  • This is a real mystery (to me, at least).

    Your .NET 3.5 verifies as OK, yet you say the entire v3.5 folder is missing under the C:\Windows\Microsoft.NET\framework folder.

    Is your Windows 7 64 bit? If so, do you find a v3.5 folder under C:\Windows\Microsoft.NET\framework64?

    I have three things you can try (in order of cost):

    1. Try repairing the embedded 3.5 on your system using the procedure explained here:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    2. Try copying an entire v3.5 folder from another Windows 7 system to your system.

    3. Reinstall Windows 7.

    • Proposed as answer by Ego Jiang Friday, March 8, 2013 6:56 AM
    • Marked as answer by Ego Jiang Tuesday, March 12, 2013 1:14 AM
    Thursday, March 7, 2013 8:50 PM
  • I tried to install this product on two different known-good Win 7 systems. In both cases, it failed to find the embedded .NET Framework 3.5 SP1.

    This situation happens when the software, or its installer, is not designed for modern Windows with embedded .NET Frameworks.

    You need to contact the publishers of this editor and ask them for a fix or updated version.

    • Marked as answer by Ego Jiang Tuesday, March 12, 2013 1:14 AM
    Saturday, March 9, 2013 2:40 PM

All replies

  • What do you see when you when...

    Start->Control Panel->Programs and Features...

    Click Turn Windows Features on and off...

    Do you see "Microsoft .NET Framework 3.5.1" in your features list? Is it fully activated?

    Try this verification tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 3.5 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    FWIW, I agree it's add that you don't find a v3.5 folder under the path you show. I checked two WIn 7 systems here and found the v2.5 folder.

    Thursday, March 7, 2013 3:20 PM
  • [03/07/13,10:57:50] Beginning of new SetupVerifier activity logging session
    [03/07/13,10:57:50] Activity log file location: C:\Users\ADMINI~1\AppData\Local\Temp\setupverifier_main_03-07-13_10.57.49.txt
    [03/07/13,10:57:50] Error log file location: C:\Users\ADMINI~1\AppData\Local\Temp\setupverifier_errors_03-07-13_10.57.49.txt
    [03/07/13,10:57:50] Build created on September 10, 2012
    [03/07/13,10:57:50] Detected operating system: Windows 7 (x86)
    [03/07/13,10:57:50] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [03/07/13,10:57:50] Install state for .NET Framework 1.0: not installed.
    [03/07/13,10:57:50] Install state for .NET Framework 1.1: not installed.
    [03/07/13,10:57:50] Install state for .NET Framework 2.0: installed with service pack 2.
    [03/07/13,10:57:50] Install state for .NET Framework 3.0: installed with service pack 2.
    [03/07/13,10:57:50] Install state for .NET Framework 3.5: installed with service pack 1.
    [03/07/13,10:57:50] Install state for .NET Framework 4 Client: not installed.
    [03/07/13,10:57:50] Install state for .NET Framework 4 Full: not installed.
    [03/07/13,10:57:50] Install state for .NET Framework 4.5: not installed.
    [03/07/13,10:57:50] Windows directory: C:\Windows

    Last 15 lines:

    [03/07/13,10:58:34] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [03/07/13,10:58:34] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [03/07/13,10:58:34] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [03/07/13,10:58:34] ExecutablePath = 'Netfx20TestApplication.exe'
    [03/07/13,10:58:34] FriendlyName = '.NET Framework 2.0 test application'
    [03/07/13,10:58:34] TimeoutSeconds = '300'
    [03/07/13,10:58:34] WaitOnExit = 'true'
    [03/07/13,10:58:34] Silent = 'true'
    [03/07/13,10:58:34] Launching process 'Netfx20TestApplication.exe' now
    [03/07/13,10:58:35] Process successfully launched. Waiting 300 seconds for it to complete.
    [03/07/13,10:59:10] Process 'Netfx20TestApplication.exe' exited with return code 0
    [03/07/13,10:59:10] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [03/07/13,10:59:10] File C:\Windows\system32\netfxperf.dll (version 4.0.31106.0) is installed on the system
    [03/07/13,10:59:10] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [03/07/13,10:59:10] Verification succeeded for product .NET Framework 3.5 SP1

    When run the application GaitoBotAiml Editor (that why i need .net framework 3.5s1) it says unable to install or run this application The application requires WindowBase version 3.0.0.0 be installed in Global Assembly Cache( GAC) First.

    Thursday, March 7, 2013 7:04 PM
  • This is a real mystery (to me, at least).

    Your .NET 3.5 verifies as OK, yet you say the entire v3.5 folder is missing under the C:\Windows\Microsoft.NET\framework folder.

    Is your Windows 7 64 bit? If so, do you find a v3.5 folder under C:\Windows\Microsoft.NET\framework64?

    I have three things you can try (in order of cost):

    1. Try repairing the embedded 3.5 on your system using the procedure explained here:

    http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

    2. Try copying an entire v3.5 folder from another Windows 7 system to your system.

    3. Reinstall Windows 7.

    • Proposed as answer by Ego Jiang Friday, March 8, 2013 6:56 AM
    • Marked as answer by Ego Jiang Tuesday, March 12, 2013 1:14 AM
    Thursday, March 7, 2013 8:50 PM
  • i am using windows 7 ultimate on 32bits (x86) laptop .

    can you try to run GaitoBotAiml Editor in your pc.

    Saturday, March 9, 2013 5:52 AM
  • I tried to install this product on two different known-good Win 7 systems. In both cases, it failed to find the embedded .NET Framework 3.5 SP1.

    This situation happens when the software, or its installer, is not designed for modern Windows with embedded .NET Frameworks.

    You need to contact the publishers of this editor and ask them for a fix or updated version.

    • Marked as answer by Ego Jiang Tuesday, March 12, 2013 1:14 AM
    Saturday, March 9, 2013 2:40 PM