locked
How can I tell msbuild to honor AppxAutoIncrementPackageRevision == true?

    Question

  • In vs 2012 professional, I right-clicked on my project, chose store > create app packages...
    Then in the wizard I chose:

    "Do you want to build packages to upload to the Windows Store?" > No
    Output location: "C:\packages\MYPROJECT\"
    Version: 1.1.13.1
    Automatically increment: checked

    Select the packages to create and the solution configuration mapping:|
    Architecture: Neutral
    Solution Configuration: Debug (Any CPU)

    After I click create the package is properly created in "C:\packages\MYPROJECT\MYPROJECT_1.1.13.1_AnyCPU_Debug_Test"

    I also noticed the .csproj file is updated to include -
       <AppxAutoIncrementPackageRevision>True</AppxAutoIncrementPackageRevision>

    My problem is that when I run msbuild from the command line -

      msbuild MYPROJECT.csproj /target:Rebuild,Publish /p:Configuration=Debug /p:platform="Any Cpu"

    the version is not incremented and the package is not created.

    - If I delete the MYPROJECT_1.1.13.1_AnyCPU_Debug_Test and run msbuild, it works and creates the MYPROJECT_1.1.13.1_AnyCPU_Debug_Test package again.

    - If I manually edit the Package.appxmanifest file and increment the version to 1.1.13.2 and run msbuild, it works and creates the MYPROJECT_1.1.13.2_AnyCPU_Debug_Test package.

    How can I make msbuild honor the AppxAutoIncrementPackageRevision == 'true' option and increment the version and create the package?

    Thursday, October 18, 2012 7:08 PM

All replies

  • Hi,

    Was a solution found to this? I am also looking for doing build with msbuild with auto increment of version number.


    -- Thanks Jithin Emmanuel

    Friday, December 21, 2012 4:52 AM
  • Hi,

    Did somebody find a solution ?

    I have the same issue with VS 2013.

    Wednesday, December 3, 2014 4:12 PM