locked
IIS 8.0 - FTPS : can log in then list/add/delete directories, but cannot download/upload files RRS feed

  • Question

  • User-1072283057 posted

    Hi,

    I am struggling with something I don't understand about my FTPS site. W2K12 server (with latest updates) IIS 8.0, FTPS site in IIS.

    My users are able to log in and can list or add directories. But, when they try to upload a file it doesn't work. The files seems to be uploaded but it is immediately deleted. Tried with Filezilla and CoreFTP and I get the same error message : Answer : 550 Error : cannot upload file

    Users are in a group of "Ftpusers" that is allowed to write on the directories plus I manually added the sames rights to the users accounts.

    I have no idea what the issue could be.

    Has anyone ever faced this issue ?

    Thx a lot.

    Monday, February 25, 2019 5:25 PM

All replies

  • User690216013 posted

    Learn Process Monitor and use it to check which account is used to write to the file location.

    Monday, February 25, 2019 10:59 PM
  • User-1072283057 posted

    Thanks for your answer lextm.

    I've tried PM.exe.

    What I see :

    • svchost.exe --> CreateFile --> SUCCESS --> Desired Access: Read Attributes, Delete | Disposition: Open | Options: Non-Directory File, Open Reparse Point | Attributes: n/a | ShareMode: Read, Write, Delete | AllocationSize: n/a | Impersonating: SERVERNAME\USERNAME | OpenResult: Opened

    Then :

    • svchost.exe --> QuerySecurityFile --> SUCCESS --> information : Attribute
    • svchost.exe --> QueryAttributeTagFile --> SUCCESS --> Attributes : A, Reparse Tag: 0x0
    • svchost.exe --> SetDispositionInformationFile --> SUCCESS --> Delete : True

    I  definitely don't understand why the file is deleted.

    Tuesday, February 26, 2019 3:22 PM
  • User-848649084 posted

    Hi,

    In may opinion you could check your firewall setting and anti-virus software,this may cause the issue.

    Regards,

    Jalpa.

    Tuesday, March 5, 2019 8:28 AM