locked
Lightswitch 2011, IssueTracker application deployed - Desktop works but web wont work RRS feed

  • Question

  • I have used the IssueTracker application as it is and deployed on a production server (win2008 R2). Enabled the Forms authentication method..

    the desktop application works when the data is accessed from client machines. Authorized users are able to work on the application. Same application was deployed using Web. But this one displays the login screen and users can login. But any of the other menus cant be used. The following error dialog appears:

    An error occurred while running the screen.
    Error details: User does not have access to the invoked operation.  Your session may have timed out.  Please restart the application.  Operation name: 'CurrentEmployee'.

    On clicking OK, the other message is "Invalid Operation. Dispatcher has been stopped."

    On the Win 2008 R2 server where it is deployed, everything works. But when the client accesses the webpage, the above errors are showing.

    I have searched the forums, found some references to session state, timeo out, machine key, etc so I disabled the session State in IIS. Still wont work.

    Any clues?

    Thursday, March 3, 2016 6:04 AM

Answers

  • Deploying a Lightswithch application is not that much easy. I got one error after another, I am listing them below

    1. Load operation failed to query 'GetAuthenticationInfo'. The remote server returned an error: NotFound

    2. http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.41212.0&File=System.Windows.dll&Key=HttpWebRequest

    3. An error occurred while establishing a connection to SQL Server instance '.\SQLEXPRESS'.
    Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed. C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\LightSwitch\v1.0\Microsoft.LightSwitch.targets.

    Finally I consolidated all the info and then repaired/reinstalled .Net 4 client profile, uninstalled/installed IIS manager, 3.5 WCF, installed .Net 4.5 and its patches.

    Finally it is working now on web mode. But could not pinpoint to 1 single issue as the answer.

    • Marked as answer by kesk Monday, March 14, 2016 12:16 PM
    Monday, March 14, 2016 12:16 PM

All replies

  • An error occurred while running the screen.
    Error details: User does not have access to the invoked operation.  Your session may have timed out.  Please restart the application.  Operation name: 'CurrentEmployee'.Hi,

    Hi,

    According to the error message above, it's recommended to open your web.config and add this in system.web section:  <sessionState timeout="whatever timeout"></sessionState>. Check whether it helps.

    If you could give more hints about this issues, we can look into it further.

    Regards,

    Angie


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, March 8, 2016 5:38 AM
  • Deploying a Lightswithch application is not that much easy. I got one error after another, I am listing them below

    1. Load operation failed to query 'GetAuthenticationInfo'. The remote server returned an error: NotFound

    2. http://go.microsoft.com/fwlink/?linkid=106663&Version=5.1.41212.0&File=System.Windows.dll&Key=HttpWebRequest

    3. An error occurred while establishing a connection to SQL Server instance '.\SQLEXPRESS'.
    Failed to generate a user instance of SQL Server due to a failure in starting the process for the user instance. The connection will be closed. C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\LightSwitch\v1.0\Microsoft.LightSwitch.targets.

    Finally I consolidated all the info and then repaired/reinstalled .Net 4 client profile, uninstalled/installed IIS manager, 3.5 WCF, installed .Net 4.5 and its patches.

    Finally it is working now on web mode. But could not pinpoint to 1 single issue as the answer.

    • Marked as answer by kesk Monday, March 14, 2016 12:16 PM
    Monday, March 14, 2016 12:16 PM