none
Error 0023: Input dataset has unsupported target column xxx while using the Rest API created by Azure ML

    Question

  • I have set up an AML experiment for textual analysis as a binary classifier to detect spam. I have just 2 columns in my dataset - Text and IsSpam. I am Extracting N-Gram features from text. I have got good results in terms of the AUC and F1score. I would like to see results via Test request-response and make calls using the deployed web service. When I run this, i get the following error - Extract N-Gram Features from Text : Error 0023: Input dataset has unsupported target column "Text".

    Additional details :

    Error Message: Extract N-Gram Features from Text : Error 0023: Input dataset has unsupported target column "Text".
    Site Path: /workspaces/98829a3a0f97485da9f3737119afded5/webservices/5c6c0988d6044d14838f7dfada4fda58/endpoints/default/test/rrs
    Activity ID: 82e53138-b3b9-4a94-8695-0b8152c505ac
    Request ID: 847fdb28-a1e6-452d-8622-b71332701baf
    Workspace ID: 98829a3a0f97485da9f3737119afded5
    Workspace Type: PaidStandard
    User Role: Owner
    Tenant ID: 72f988bf-86f1-41af-91ab-2d7cd011db47

    I tried variations of the experiment to fix this error and nothing works. Would appreciate any pointers in this regard.

    Regards,

    Shruthi

    Thursday, April 20, 2017 10:23 PM

Answers

  • Hi Shruthi,

    Sorry about the trouble you are having.  In the predictive experiment, can you please change the options on the “Extract N-Gram Features From Text” module to:

     

    Use filter-based feature selection -> False

    Vocabulary mode -> Read Only

     

    Also, in the predictive experiment, you need to pass the output vocabulary from the training experiment (for that same module) to the input vocabulary port of the predictive experiment (for that Extract N-Gram Features module).

     

    Please let me know if you still experience issues – if needed, we can discuss the changes on a skype call.

    Thank you, Ilya

    • Marked as answer by ShruthiKC Friday, April 21, 2017 5:42 PM
    Friday, April 21, 2017 1:57 PM

All replies

  • Hi Shruthi,

    Sorry about the trouble you are having.  In the predictive experiment, can you please change the options on the “Extract N-Gram Features From Text” module to:

     

    Use filter-based feature selection -> False

    Vocabulary mode -> Read Only

     

    Also, in the predictive experiment, you need to pass the output vocabulary from the training experiment (for that same module) to the input vocabulary port of the predictive experiment (for that Extract N-Gram Features module).

     

    Please let me know if you still experience issues – if needed, we can discuss the changes on a skype call.

    Thank you, Ilya

    • Marked as answer by ShruthiKC Friday, April 21, 2017 5:42 PM
    Friday, April 21, 2017 1:57 PM
  • Thank you very much Ilya! 

    I tried the changes suggested and it works now J

    Regards,

    Shruthi

    Friday, April 21, 2017 5:44 PM