locked
Command line says "IIS does not seem to be installed" RRS feed

  • Question

  • User-1744950148 posted

    I'm trying to install FastCGI on my server so that I can install the non-thread safe version of PHP 5.2.6. When I try to add the .php extension mapping from the command line using:

    cscript fcgiconfig.js -add -section:"PHP" -extension:php -path:"c:\php\pgp-cgi.exe"

    I get a "IIS does not seem to be installed" message. However, IIS6 is installed - I can acces it via the Internet Information Services Manager in Windows and I'm successfully running a few test sites in IIS.

    The server is running on Windows Server 2003 Standard Edition SP2 and IIS6. I also tried it on a desktop pc running IIS 5.1 and Windows XP SP2 and got the same error. But then I also tried the above cscript command on a second Windows Server 2003 Standard Edition SP2 and IIS6 machine and it worked, so it's not bad syntax.

    What is causing the "IIS does not seem to be installed" error and how do I overcome it?

    Thanks.

    Tuesday, October 14, 2008 7:19 AM

All replies

  • User-1653247517 posted

    Hi,

    I opened fcgiconfig.js and IisInstalled check is made by verifying existence of %windir%\system32\inetsrv\inetinfo.exe. Can you check if you have this file on your machine? My first doubt was that you might be running fcgiext.js in wow64 window but seems like script throws an error if you try to do so. I wonder how you have IIS running successfully without inetinfo.exe.

    Thanks,
    Kanwal

    Tuesday, October 14, 2008 1:08 PM
  • User-1744950148 posted

    Thanks Kanwal. The inetinfo.exe file is on my machine in the %windir%\system32\inetsrv\ folder.

    The file version number is: 6.0.3790.3959 (srv03_sp2_rtm.070216-1710)
    Size: 14.0 KB (14,336 bytes)

    I've managed to get FastCGI and PHP running by manually configuring the fcgiext.ini file and IIS, but I am still unable to add the .php mapping via the cscript fcgiconfig.js -add method.

    And I'm quite certain the IIS IS running on the box because I'm able to connect to the test sites that I have created via the Internet Information Services Manager, eg http://localhost/testsite.

    Also, the IIS Admin and World Wide Web Publishing services are running fine so I'm "quite convinced" that IIS is installed.

    Tuesday, October 14, 2008 3:41 PM