locked
APP ERROR with Excel 2013 RTM RRS feed

  • Question

  • The Apps for Office feature worked fine for me with the Office 2013 Preview.

    Now, using the RTM, nothing works. I try to insert an app, and every time I get an error:

    APP ERROR: Sorry, we couldn't load the app
    because your browser version is not
    supported. Click here for a list of supported
    browser version.

    I have IE 9.0 installed, which qualifies.

    Known problem?


    Tuesday, November 13, 2012 1:32 AM

All replies

  • Hi, J-Walk

    One possibility is that your build of Internet Explorer 9 isn't up to date. Please download the latest version of IE 9 here: http://windows.microsoft.com/en-US/internet-explorer/downloads/ie-9/worldwide-languages

    Then let me know whether you can successfully start an app.

    Thanks!

    Wednesday, November 14, 2012 12:52 AM
  • Thanks for the suggestion. My IE 9 is up to date -- so up to date that when I tried to reinstall it using that link, it failed because it claimed the version I have is later than the one I tried to install from the download.

    I'm being reminded once again why I abandoned IE years ago. :)

    Wednesday, November 14, 2012 4:21 PM
  • Ok, let's check something else: IE may be in a compatibility mode. To check, open IE and hit F12. Verify that the Browser Mode displayed at the top is IE9.

    If it's in a compatibility mode, change it to normal IE9 mode:

    1. Open IE
    2. Alt
    3. Tools
    4. Compatibility View settings
    5. Remove all websites and uncheck "Display all websites in Compatibility View"

    Wednesday, November 14, 2012 8:58 PM
  • No, IE9 is not in compatibility mode.

    I just noticed that I have only one Trusted App Catalogs listed (it's one that I added, to do some testing during the Preview). If I recall, my Preview version of Office 2013 included at least one other, from Microsoft. Could that be the problem?

    Thursday, November 15, 2012 3:48 PM
  • Hi J-Walk,

    The Javascript API have some change in RTM  office, Do you ues the deprecated API in your feature? you can get more information about the update for RTM  office in following link:

    http://msdn.microsoft.com/en-us/library/fp161068.aspx

    if you have any question, please contact to me.

    Tuesday, December 18, 2012 7:50 AM
  • I don't think that the deprecated API is responsible.

    The problem is that NO Apps for Office work. Every one of them gives me the same (bogus) error message.


    Wednesday, December 19, 2012 11:29 PM
  • Can  you give the error codes in RTM ?

    I want to test them and see  whether the error reappear on my local machine.

    If the error can reappear,  I think i can find reason and give you the helpful advise.

    Thanks.

    Thursday, December 20, 2012 2:47 PM
  • Hi J-Walk,

    Did you manage to solve this? I am having the same issue - I installed the Office 2013 Preview while I was testing an Excel app for office we were building and all Apps for Office were working fine but once I unistalled the preview and installed the RTM, I now get the same error message. I have double checked that I have all the prerequisites installed, can't seem to figure this one out.

    I went to Windows event logs and pulled these two Office 2013 alerts:

    When I click on the 'Apps for Office' button on the 'Insert' ribbon tab - the event log records this message:

    Failed to parse element: OfficeWebExtension

    Id=(null), DisplayName=(null), Provider=(null), StoreType=Registry, StoreId=(null)

    P1: Apps for Office

    P2: 15.0.4420.1017

    P3: 0x8004323E

    P4: New Document

    When I click on the App I would like to insert, the event log records this message:

    App Error

    Sorry, we couldn't load the app because your browser version is not supported. Click here for a list of supported browser versions.

    P1: Apps for Office

    P2: 15.0.4420.1017

    P3: 0x80042FAA

    P4:

    -Mike

    
    
    
    
    Monday, January 28, 2013 11:48 AM
  • I did not solve it. I just gave up on it for now.

    I think it might be related to another problem I'm having with Windows Update. There are two "important" updates that simply can't be installed: One of them is Windows Internet Explorer 9 for Window 7 for x64-based Systems (36.7MB). After an hour of digging around (and downloading a tool from Microsoft). the solution seems to be: Reinstall Windows. That's not an option for me right now.

    Monday, January 28, 2013 1:49 PM