locked
IIS manager not installed on my windows 7 RRS feed

  • Question

  • User-2097295820 posted

    I noticed IIS manager is not installed on my windows os.

    I have checked and I am sure it not installed there.

    But IIS it self is installed cos I enable it to run on localhost and it works. but While enabling it when I went to the Turn on Windows Features in Control Panel

    All this features below are not in my windows

    ASP
    ASP.NET
    ISAPI Extensibility
    CGI
    ISAPI Extensions
    ISAPI Filters
    Server-Side Includes.

    So right now i cant view my asp.net mvc app from the local iis

    Tuesday, September 3, 2013 10:16 AM

Answers

  • User-2097295820 posted

    Thanks alot Starain,

    Discovering that Windows 7 Basic is very limiting for a developer I decided to upgrade my OS to windows Ultimate.

    Right now I have stalled visual studio 2012 which I used to develop and I have activate the the local IIS.

    I confirm that it is on with the image IIS 7 through localhost from the browser.

    I deployed my project to the web directory on my local iis unfortunately when I try to view the web application I get the error

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, September 4, 2013 12:10 PM
  • User-2097295820 posted

    I added this to my web.config file and the error was solved

      <system.webServer>
    
    ....
    
      <modules runAllManagedModulesForAllRequests="true"/>
    
    
    ....
    



    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, September 4, 2013 12:42 PM

All replies

  • User100899815 posted

    Control Panel -> program and features -> on the left pane, select turn on /off windows features ->

    and you should navigate to the node and check the checkbox

    http://imgur.com/Y51ZUzm

    Tuesday, September 3, 2013 10:48 AM
  • User-2097295820 posted

    I have done that. does values I pasted above are not there on my computer.

    Could it be because I am using windows 7 Home edition.

    Tuesday, September 3, 2013 11:14 AM
  • User100899815 posted

    Yes, IIS manager is not available on windows 7 home basic. have you consider using IIS express? http://www.iis.net/learn/extensions/introduction-to-iis-express/iis-express-overview

    Tuesday, September 3, 2013 1:33 PM
  • User-1454326058 posted

    Hi skliz4rel,

    Thanks for your post!

    By default, IIS is not installed on Windows® 7. You can install IIS by clicking Windows Features in Advanced Options under Programs in Control Panel.

    Based on you saidBut IIS it self is installed cos I enable it to run on localhost and it works”, I would like to know, what’s tool that you used?

    In Visual Studio 2010, by default it use the Visual Studio Development Server to run project.

    In Visual Studio 2012, by default it use the IIS Express to run the project.

    IIS Express is included with WebMatrix too.

    Note: In Visual Studio, you can right click your project and choose properties, then click Web tab, you can find the settings of Server in Servers section.

    Based on you said “I have done that. does values I pasted above are not there on my computer”, do you mean the section of Application Development Features is empty? (Internet Information Services=>World Wide Web Services=>Application Development Features)

    Here is a reference that may benefit you.

    #Installing IIS 7 on Windows Vista and Windows 7

    http://www.iis.net/learn/install/installing-iis-7/installing-iis-on-windows-vista-and-windows-7

    Thanks

    Best Regards

    Wednesday, September 4, 2013 5:04 AM
  • User-2097295820 posted

    Thanks alot Starain,

    Discovering that Windows 7 Basic is very limiting for a developer I decided to upgrade my OS to windows Ultimate.

    Right now I have stalled visual studio 2012 which I used to develop and I have activate the the local IIS.

    I confirm that it is on with the image IIS 7 through localhost from the browser.

    I deployed my project to the web directory on my local iis unfortunately when I try to view the web application I get the error

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, September 4, 2013 12:10 PM
  • User-2097295820 posted

    I added this to my web.config file and the error was solved

      <system.webServer>
    
    ....
    
      <modules runAllManagedModulesForAllRequests="true"/>
    
    
    ....
    



    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, September 4, 2013 12:42 PM