none
Word Object Model and spell check in Outlook 2007/2010 RRS feed

  • Question

  • This was originally asked in Outlook for Developers:

    When doing a spell check in Outlook, some of the text is tagged so that it is not checked by the spell checker.

    The following message displays:

    The spelling and grammar check is complete.
    Text markes with "Do not check spelling or grammar" was skipped.

    In this case the items skipped were the original quoted message on a reply and the signature block.

    How can I set the property "Do not check spelling or grammar" on paragraphs that I insert into an e-mail message using an addin?

    Also, how does Outlook know that a "Signature" is a special paragraph, and not just some other user inserted text?

    Although an Outlook question it is posted here as it involes the Word Object Model.

     

     

     


    Mark Wilson
    Tuesday, November 15, 2011 8:24 PM

Answers

  • Hello,

    Use Range.NoProofing = true.

    Signature is wrapped with a bookmark called _MailAutoSig. Getting it requires setting Document.Bookmarks.ShowHidden=true.


    Regards from Belarus (GMT + 2),

    Andrei Smolin
    Add-in Express Team Leader
    • Marked as answer by Mark_Wilson Saturday, November 19, 2011 8:07 PM
    Wednesday, November 16, 2011 7:26 AM

All replies

  • Hello,

    Use Range.NoProofing = true.

    Signature is wrapped with a bookmark called _MailAutoSig. Getting it requires setting Document.Bookmarks.ShowHidden=true.


    Regards from Belarus (GMT + 2),

    Andrei Smolin
    Add-in Express Team Leader
    • Marked as answer by Mark_Wilson Saturday, November 19, 2011 8:07 PM
    Wednesday, November 16, 2011 7:26 AM
  • Thanks.  That works.

     


    Mark Wilson
    Saturday, November 19, 2011 8:08 PM