locked
NTDETECT.COM not added to image RRS feed

  • Question

  • hi,

    I've got a problem with Target Designer when building my WES 2009 image. I've noticed that the file "NTDETECT.COM" was not added in my built image directory. 
    So I checked my configuration to see that the "NT Hardware Detect" component shows something really weird. Under the file section, I see the NTDETECT.COM file but the source file is at 0 bytes. Why is that? If I disable the component and re-enable it, it stays the same but if I delete it from my configuration and add it back again, I see that the size changes to 49152 bytes. But if I build my image, it gets back to 0 byte and it is not added to my built image.

    I've just installed the latest QFEs, which are the security updates from September 2009 and the EWF optional one also. I've made sure that I installed the ones for WES 2009. Also, I've tried with an other OS design (other .slx file configuration) where I didn't update the component for the QFEs and the NTDETECT.COM is built correctly. I've compared the 2 build logs and in the one where NTDECTECT isn't build, I dont see it in the final list compiling the estimated component sizes.

    Can someone explain me this weird behaviour and have a way to solve it? My fear is also that some "less" critical component could also see the same fate and only notice it when its too late (image deployed in the field). Hope that some can help me!

    Regards

    Bhentai
    Wednesday, October 28, 2009 9:41 PM

Answers

  • I've found the reason why I got this behaviour. I had my configuration set to the debug build type when building my image. I just put it back to Release and the problem was solved. Thanks for leaving an option that causes problems and doesn't let you boot your image.
    • Marked as answer by Bhentai Wednesday, October 28, 2009 10:27 PM
    Wednesday, October 28, 2009 10:27 PM