locked
Report Deployment Error: The permissions granted to user XXX\YYY' are insufficient for performing this operation._ RRS feed

  • Question

  • Hi,

    This is my first time to use SSRS but I'm stuck with this error upon deploying my report.  I'm using SQL2012 Express Edition with advance services and windows 8 OS.  I have almost exhausted all possible solutions presented in the forum but none would fix my problem.  please help, I'm struggling with this for 3 days now.

    Rkage

    Friday, September 12, 2014 2:06 PM

Answers

All replies

  • At a minimum, the user account which you are running SSDT-BI with needs to have Publisher permissions on the folder in question.  You can grant access to said user by clicking "Folder Settings" and click "New Role Assignment" and adding the user.  When you first login to report manager (i.e., http://yoururl/reports) you should see "Folder Settings" in the toolbar.  "Content Manager" would be the highest permissions you can grant.
    Friday, September 12, 2014 2:57 PM
  • Agree with JJordheim...  Make sure your SSRS service account has access on Report server databases and also you have full have access on db side.  Try all these things.  If you still have the same issue please try to post the error message here.  We will try to explore other options.
    Friday, September 12, 2014 3:15 PM
  • ok this is what I got.  But still get the error when deploying my report.     By the way, my service account in my configuration manager is set to "Local System".


    Friday, September 12, 2014 11:20 PM
  • Possible duplicate,

    http://social.msdn.microsoft.com/Forums/sqlserver/en-US/b1ccddc4-9b72-44bf-a676-5dabfd07d71f/the-permissions-granted-to-user-are-insufficient-for-performing-this-operation?forum=sqlreportingservices

    Highlighting what was discussed in the thread, make sure you are running the BIDS and IE as administrator by using "Run as Administrator".


    Be the change you want.

    • Proposed as answer by Katherine Xiong Monday, September 15, 2014 6:03 AM
    • Marked as answer by RKage Wednesday, September 17, 2014 1:21 PM
    Saturday, September 13, 2014 12:04 AM
  • thanks
    Thursday, May 21, 2015 9:51 AM