locked
Content within nested repeating section content control RRS feed

  • Question

  • Hi,

    I have a word template with nested repeating section content controls that are mapped to a CustomXml.

    I illustrate with a couple of pictures, in picture one you see the document in design mode with content controls.

    In picture two you see the xml mapping pane.

    As you can see in picture number two there are no Conclusion element below the marked Conclusions element.
    Still, the table within the repeating section content named "ImpConclusions" control is visible(see picture one).

    However, if i make sure there are no Remark elements underneath the Remarks element the table disapears.
    Could it be a glitch somewhere or is it something that i have overlooked with nested repeating section controls?

    Br,
    /Peter


    Peter


    Wednesday, September 17, 2014 11:44 AM

All replies

  • Are you using a custom xml? could you share it?

     

    Thursday, September 18, 2014 7:46 AM
  • Of course, here is a sample

    <Document xmlns="http://schemas.customer.se/template/bl">
      <Content>
        <Metadata>
          <IsFSBInnevarandeAr>
          </IsFSBInnevarandeAr>
          <IsFSBAPInnevarandeAr>
          </IsFSBAPInnevarandeAr>
          <IsFSBAPInnevarandeArFSBForegaendeAr>
          </IsFSBAPInnevarandeArFSBForegaendeAr>
          <CreatedFromTabPath>
          </CreatedFromTabPath>
          <GeneratedBy>
          </GeneratedBy>
          <GeneratedDate>
          </GeneratedDate>
          <TeamMember>
          </TeamMember>
        </Metadata>
        <RedThread>
          <Tabs>
            <ImplementationTab name="">
              <AuditTypes>
                <AuditType name="">
                  <Remarks>
                    <Remark name="">
                      <!--Can contain multiple Conculsion elements, for each conculsion you have a process element as well as observations, open questions and conclusion summary-->
                      <Conculsions>
                        <Conculsion>
                          <Processes>
                            <Process name="">
                              <Process name="">
                                <Process name="" />
                              </Process>
                            </Process>
                          </Processes>
                          <PreviousObservations>
                            <Document id="" title="" index="" projectId="">
                              <Comment>
                                <Text>
                                  [Content from Rich text content control]
                                </Text>
                              </Comment>
                            </Document>
                          </PreviousObservations>
                          <!--Can contain multiple Document elements-->
                          <Observations>
                            <Document id="" title="" index="" projectId="">
                              <Comment>
                                <Text>
                                  [Content from Rich text content control]
                                </Text>
                              </Comment>
                            </Document>
                          </Observations>
                          <!--Can contain multiple Document elements-->
                          <OpenQuestions>
                            <Document id="" title="" index="" projectId="">
                              <!--Can contain multiple Comment elements-->
                              <Comment>
                                <Text>
                                  [Content from Rich text content control]
                                </Text>
                              </Comment>
                            </Document>
                          </OpenQuestions>
                          <!--Can contain multiple Document elements-->
                          <ConclusionSummaries>
                            <Document id="" title="" index="" projectId="">
                              <Comment>
                                <Text>
                                  [Content from Rich text content control]
                                </Text>
                              </Comment>
                            </Document>
                          </ConclusionSummaries>
                        </Conculsion>
                      </Conculsions>
                    </Remark>
                  </Remarks>
                </AuditType>
              </AuditTypes>
            </ImplementationTab>
          </Tabs>
        </RedThread>
      </Content>
    </Document>


    Peter

    Thursday, September 18, 2014 8:33 AM
  • Hi,

    Thank you for posting in the MSDN Forum.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Sorry for any inconvenience and have a nice day!

    Best regards.


     


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 18, 2014 8:48 AM
  • Hi,

    Just wondered if you have found anything yet?

    Have a nice weekend!

    Br,
    /Peter


    Peter

    Friday, September 19, 2014 1:58 PM
  • We have involved Developer Support to look in to this issue. Request your patience while they investigate the problem and get back to you.

    Microsoft Office Support

    Monday, September 22, 2014 7:24 PM
  • Hi Peter,

    I would like to know which version of Office you are using. It would be helpful if you could upload a sample document containing the content controls through OneDrive and also share the repro steps.

    Thanks,

    Anush.

    Tuesday, September 23, 2014 3:58 PM
  • Hi,

    Thanks for getting back to me.
    The version of Office that we are running is Office 2013 Professional Plus(version 15.0.4569.1506)
    I will upload a sample document shortly and share the link with you. The custom xml mapped to the content
    controls lies within the sample document.

    Br,
    /Peter


    Peter

    Wednesday, September 24, 2014 7:40 PM
  • Hi again,

    You can download the sample document "Sample.docm" from the following link http://1drv.ms/1raxoUr
    In order to reproduce the problem you need only to open the document and expand the custom xml with the
    namespace http://schemas.[customer].se/template/bl

    See the pictures above for a more detailed description of the problem.

    Br,
    /Peter


    Peter

    Wednesday, September 24, 2014 7:51 PM
  • Hi Peter,

    Looking at the complexity of your issue,it falls into the paid support category which requires a more in-depth level of support.  Please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone”.

    Thanks,

    Anush.

    Tuesday, September 30, 2014 6:30 PM
  • Hi,

    Okay, we do have a paid support agreement so i will consider taking that route.
    However, as feedback, i would have liked this information a little sooner. A week has
    gone by which could have been more productive.

    Thanks

    Br,
    /Peter


    Peter

    Wednesday, October 1, 2014 12:51 PM
  • Hi Peter,

    I was trying to have a quick look at the issue and see if it could be resolved. Based on the complexity of the issue , it looks like it requires more time and effort, I would suggest you to go for the paid support option. 

    Thanks,

    Anush.  

    Wednesday, October 1, 2014 2:07 PM
  • Hi,

    Just for completion of this post i wish to inform about our findings. Our investigation together with Microsoft show that the reason that the table above is shown despite the fact that there is no record within the underlying CustomXml to back it up is that word and the mapping between content controls and Custom xml depends on that there are at least one record within the CustomXml. So, to relate to the above information, you cannot have an element of Conclusions that have no Conclusion elements, you need to have at least one.

    Also, word depends heavily on the CustomXml to be complete. You get unpredictable results if you have a CustomXml where you have mapped content controls to elements that do not exists within the CustomXml.

    Hope this helps someone else.

    Cheers,

    /Peter


    Peter

    Thursday, November 27, 2014 2:08 PM