none
having problems creating a VM from existing VHD RRS feed

  • General discussion

  • I am trying to create the same VM using different way, I uploaded the VHD to Azure and when I tried to create a Disk on Azure with that VHD I am getting this error """"Failed to create disk 'Hyper-VVM'. Error: At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug  for usage details.  """"

    I am also not able to start VM that is created from the same VHD on Hyper-V on an Azure VM.

    Monday, February 11, 2019 3:50 PM

All replies

  • Did you follow the steps in this article? There are a number of specific things that need to be set on the VHD for this to work:

    • It can only be a gen 1 VHD format file
    • It must be a fixed size disk (not dynamically expanding)
    • You need to set a number of registry keys as per the article
    • You need to set up the windows firewall appropriately
    • You need to Sysprep (if you want to use this as a general image).

    I'd also recommend looking at the deployment log in the portal to get better error messages.


    Sam Cogan Microsoft Azure MVP
    Blog | Twitter

    Monday, February 11, 2019 5:34 PM
  • I get this error when I try to convert VHD from Dynamically expanding to Fixed

    Monday, February 11, 2019 7:12 PM
  • I have also uploaded same VHD to Azure storage and when I try to create a Disk from it I get this error :

    Monday, February 11, 2019 7:18 PM
  • Please confirm that you have provided a different output vhd name from the input vhd when you ran the conversion? This can cause this error.

    If you have been unable to convert it to a static disk then uploading it to Azure and trying to use it is no good, it will not work until you convert it.


    Sam Cogan Microsoft Azure MVP
    Blog | Twitter

    Wednesday, February 13, 2019 10:38 AM
  • I have tried to convert it to static using Hyper-V console and that didn't work as you can see in the screenshot above, I have downloaded the VHD from here https://www.microsoft.com/en-us/download/details.aspx?id=5002 , I am trying to create a VM out of this VHD, so far it is failing for both Hyper-V and Azure, in Hyper-V VM creation wizard it errors out when I try to convert it to Dynamic.  could you please try download that VHD and convert it.
    Friday, February 15, 2019 1:25 PM