locked
I can't build any Android project!!! RRS feed

  • Question

  • User73815 posted

    For weeks I'm trying to build the Android project with no success! I got any type of erros, such as: * Error CS0117 'Resource.String' does not contain a definition for 'statusbarnotificationinfooverflow' (ALL resources are missing) * Error "aapt.exe" exited with code - * (The code always varies) * Please download https://dl-ssl.google.com/android/repository/androidm2repositoryr29.zip and extract it to the /Users/MyUser/.local/share/Xamarin/Android.Support.v4/23.3.0.0/content directory. (I got this error to any folders on this directory) * Severity Code Description Project File Line Suppression State Error The file "obj\Debug\android\bin\packaged_resources" does not exist.

    And others. I try to build: * On Xamarin Studio on a Mac. * On Visual Studio inside the Parallels Desktop, on a Mac. * On Visual Studio in Windows. 3 different machines!!!

    My Xamarin on mac and windows are updated. My VS is Community 2015. I install ALL the items, for all version, on Android SDK Manager above the 5.1 Lollipop. I try to set up the target version.

    Even I create a new project, and build without any changes, with that message "Welcome to Xamarin Forms!", I got the same erros!!

    Monday, May 2, 2016 2:03 PM

All replies

  • User57571 posted

    This error is related to v4 and v7 packages, there are quite a lot forum post about this:

    https://forums.xamarin.com/discussion/32346/install-android-support-library-available-in-sdk-installer-error-doesnt-leave-us

    https://forums.xamarin.com/discussion/56336/build-unsuccessful-error-with-android-project-in-xamarin-forms

    https://forums.xamarin.com/discussion/60470/unable-to-create-build-new-project

    https://forums.xamarin.com/discussion/54696/build-errors-in-android-apps-with-xamatin-forms-dependencies

    https://forums.xamarin.com/discussion/42982/android-build-failure-unzipping-failed

    In my personal case I have done the unzipping manually also I have delete the v4 and v7 packages manually and from the project and install them again, clean then rebuild the project and that did the unzipping hope this info helps.

    Monday, May 2, 2016 2:52 PM
  • User224904 posted

    I have the same problem.

    es.stackoverflow.com/questions/9925/error-al-compilar-proyecto-android-con-xamarin-visual-studio-2015

    can you help me please?

    Thanks.

    Jose Poma

    Saturday, May 14, 2016 4:50 AM
  • User51749 posted

    Same problem for me. This is quite a blocker.

    Tuesday, June 28, 2016 12:55 PM
  • User229323 posted

    It is really a blocker. I can't do anything even creating a new app errors out once build. I have updated to the latest most recent stable Xamarin still did not help.

    Sunday, July 3, 2016 9:26 PM
  • User239091 posted

    I have the same error. Jut downloaded xamrin for VS2013 created a blank project. Connected my samsung Android 5.1 API 22 (Also changed to android_accelrate86 same problem). getting Error 101 "aapt.exe" exited with code -1073741819. C:\Program Files\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets 1271 2 XM1 checked all resources. Just has one Icon.png file. Also deleted the package SDK version 24 same error

    Monday, July 4, 2016 6:19 AM
  • User232885 posted

    Hello, I have the same error, 1 hour ago.

    to slove this:

    Check the files name of you project, and delete special character on names. I hope help your.

    Sorry my english is poor.

    Friday, July 8, 2016 1:57 PM
  • User243303 posted

    Same issue with VS2015 ce. Created new blank android project and the appt error twice with the same number. Deleted build tools 24. Getting fed up. considering sticking with 2 codebases. Going to try 15mgm15 suggestions.

    Wednesday, July 20, 2016 2:23 AM
  • User243303 posted

    Found the issue, it was the build tools, but it was under the Tools (Preview channel) too.

    Thursday, July 28, 2016 3:24 PM
  • User268854 posted

    I found the solution to this problem that might just save a lot of people. The reason the file is not found is cause the system installed AntiVirus solution wont allow it. It is falsely flagged as a Virus of sorts. So, In my case where I am running Bitdefender Total Security 2017 with Ransomware protection on, I was prompted by Bitdefender to allow the aapt.exe to create the file in the system. After allowing it, the error is gone. I also have installed Build Tools 20, 23 and 25 just as a precaution and I had to allow all three aapt.exe files from them to create the packaged_resources.bk file.

    Tuesday, October 25, 2016 6:26 PM
  • User93424 posted

    Had the same problem. My error was in the manifest: I had Version Code (Version number) set at "1.0.0" and it wasn't allowed. It only takes integers so I had to revert to "1".

    I mixed up Version Code and Version Name.

    Tuesday, April 11, 2017 3:51 PM