none
VS2005 compatibility issues

    Question

  • Hi, 

    Does VS2005 version project is compatible with 2008 without any issues?

    Regards,

    Puneeth


    Puneeth


    • Edited by M H Puneeth Monday, November 16, 2015 7:10 AM
    Monday, November 16, 2015 6:40 AM

Answers

All replies

  • Hi Puneeth,

    As far as I know you yes its compatible Visual Studio will automatically upgrade your VS2005 project into VS2008. You could also read the below article for more information.

    How to use solutions and projects between Visual Studio 2005 and 2008

    Thanks,

    Sabah Shariq

    Monday, November 16, 2015 5:52 PM
  • In addition to Sabah's post, I'd like to point out that you are migrating from one unsupported version of Visual Studio to another. I would seriously consider migrating to Visual Studio 2015 if at all possible. Remember that the Community Edition of Visual Studio 2015 is free (assuming you are eligible).
    Monday, November 16, 2015 8:51 PM
  • Hi Brian Muth,

    I dont want to use any unsupported versions, as sabha said if it automatically upgrades to VS2008 project then I am fine. because right now I dont have much time to solve those migration errors my focus is to  to capture code coverage report for my project, that'a all. 

    Regards,

    Puneeth


    Puneeth

    Tuesday, November 17, 2015 6:06 AM
  • Hi Sabah,

    Thanks much.

    My concern for this query is different. I was in an assumption to use VS2008 for the code coverage task if there are no migration issues, but I learnt that I need Visual Studio Team System 2008 Test Load Agent product to run the manual and automated test cases in remote machine. I don't have license for this particular one.

    Let me know if you have any inputs on this.

    Regards,

    Puneeth


    Puneeth

    Tuesday, November 17, 2015 6:15 AM
  • Hi Sabah,

    Thanks much.

    My concern for this query is different. I was in an assumption to use VS2008 for the code coverage task if there are no migration issues, but I learnt that I need Visual Studio Team System 2008 Test Load Agent product to run the manual and automated test cases in remote machine. I don't have license for this particular one.

    Let me know if you have any inputs on this.

    Regards,

    Puneeth



    Puneeth

    Tuesday, November 17, 2015 6:17 AM
  • Does the same holds good for VS2010? Does 2005 solution project gets automatically upgraded to 2010 project? As I learnt I cant use VS2008 for my code coverage activity which needs VS2008 team test load agent product for testing remotely.

    Puneeth

    Tuesday, November 17, 2015 8:38 AM
  • Hi M H Puneeth,

    Yes, if your 2005 solution is opened by VS2010, it will upgrade to VS2010 project. But I don't recommended you do that. Because there are a VS2008 between VS2005 and VS2010, which may cause your project upgrade with some unknown error.

    Best Regards,
    Weiwei

    Wednesday, November 18, 2015 8:23 AM
    Moderator
  • Hi Weiwei,

    Do you mean to say that I should use VS2008 instead?

    Regards,

    Puneeth


    Puneeth

    Wednesday, November 18, 2015 8:26 AM
  • Hi M H Puneeth,

    If you want to use VS2010 to implement code coverage for testing remotely, you can try to opened VS2005 project with VS2010. If there any error, then you can operate it use VS 2010. If you get some errors when upgrade to VS2010 project, please upgrade with VS2008 first, then upgrade it from vs2008 to VS2010.

    Best Regards,
    Weiwei

    Wednesday, November 18, 2015 8:31 AM
    Moderator