none
why is the model not detected? RRS feed

  • Question

  • Hi I am trying to make my own model with the "create R Model".

    However when I try to run it the following error message appears

    Error 0063: The following error occurred during evaluation of R script:
    ---------- Start of error message from R ----------
    object 'model' not found
    ----------- End of error message from R -----------
    Start time: UTC 06/15/2016 08:38:52
    End time: UTC 06/15/2016 08:39:02

    I do not understand why this happens as I have defined my model as:

    model$factor1<-replicate(2, rnorm(20))
    model$factor2<-replicate(2, rnorm(10))
    model

    Is there any specification I am missing here?

    Wednesday, June 15, 2016 8:48 AM

Answers

  • Could you help me understand if you have already reviewed and processed the Custom R model documentation and sample that is published in the gallery. Please let me know and we can dig further on this on.

    Custom R model help: https://msdn.microsoft.com/library/azure/314e34a8-b24c-4870-afe6-2649b6fc7476

    Gallery sample experiment: https://gallery.cortanaintelligence.com/Experiment/Create-R-Model-3

    • Proposed as answer by GokhanUModerator Wednesday, June 22, 2016 2:40 AM
    • Marked as answer by GokhanUModerator Friday, June 24, 2016 2:46 AM
    • Unmarked as answer by ddjambo Wednesday, June 29, 2016 12:52 AM
    • Marked as answer by ddjambo Wednesday, June 29, 2016 12:53 AM
    Tuesday, June 21, 2016 2:37 PM
    Moderator
  • I was connecting the create model directly to "score model", since my toy example didn't actually need to be trained.

    Now I understand that no matter what, you need to connect "create R model" to "train model"

    • Marked as answer by ddjambo Wednesday, June 29, 2016 12:52 AM
    Tuesday, June 28, 2016 8:05 AM

All replies

  • Could you help me understand if you have already reviewed and processed the Custom R model documentation and sample that is published in the gallery. Please let me know and we can dig further on this on.

    Custom R model help: https://msdn.microsoft.com/library/azure/314e34a8-b24c-4870-afe6-2649b6fc7476

    Gallery sample experiment: https://gallery.cortanaintelligence.com/Experiment/Create-R-Model-3

    • Proposed as answer by GokhanUModerator Wednesday, June 22, 2016 2:40 AM
    • Marked as answer by GokhanUModerator Friday, June 24, 2016 2:46 AM
    • Unmarked as answer by ddjambo Wednesday, June 29, 2016 12:52 AM
    • Marked as answer by ddjambo Wednesday, June 29, 2016 12:53 AM
    Tuesday, June 21, 2016 2:37 PM
    Moderator
  • I was connecting the create model directly to "score model", since my toy example didn't actually need to be trained.

    Now I understand that no matter what, you need to connect "create R model" to "train model"

    • Marked as answer by ddjambo Wednesday, June 29, 2016 12:52 AM
    Tuesday, June 28, 2016 8:05 AM