locked
Windows 2008 server and SQL Server 2008 1418 error RRS feed

  • Question

  • Hi,

    Please can anyone assist? I have two servers both running Windows 2008 server and SQL Server 2008. (Not part of any domain, just a workgroup).

    When I attempt to "start Mirroring" i received Microsoft SQL Server 1418 Error Message.  I have tried restoring mirror db using different .bak, using ip address instead of FQDN and telnet to port 5022 correctly.

    Any assistance will be helpful.


    In Event Viewer: Database Mirroring Connection error 4 ' An Error occured while receiving data: '10054' (Failed to retrieve text for this error. Reason 151015)'.' for TCP:/xxx:5022'

    .
    Thanks.
    Thursday, September 18, 2008 8:45 AM

All replies

  • Error: 1418 - Microsoft SQL Server - The server network address can not be reached or does not exist. Check the network address name and reissue the command

    The server network endpoint did not respond because the specified server network address cannot be reached or does not exist.

    Fix/Workaround/Solution:

    Step 1) Your system Firewall should not block SQL Server port.

    Step 2) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Network Configuration
    Enable TCP/IP protocol. Make sure that SQL SERVER port is by Default 1433.

    Just to make sure follow one more step which may or may not be necessary.

    Step 3) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Client Configuration
    Enable TCP/IP protocol.

    Reference : BOL

     

     

    BR
    Praveen Barath

    Thursday, September 18, 2008 10:33 AM
    Answerer
  • What authentication type are you using for the DBM endpoints? Is it windows or Certificate based?

    Also check the Event Viewer for errors on both machines involved.
    Thursday, September 18, 2008 10:38 AM
  • Windows Authentication .
    Thursday, September 18, 2008 10:46 AM
  • Thanks..

    1) Firewall is switched off on both servers.
    2) TCP/IP is enabled and SQL SERVER and is set to default 1433 port

    Any other possibilities?
     
    Thursday, September 18, 2008 10:50 AM
  • How are the two SQL Server instances supposed to authenticate Windows is they aren't in a domain? Use CERTIFICATE based authentication. Monitor both machines for Security/Audit Database Mirorring Login events in Profiler.
    Please note that port 1433 has absolutely nothing to do with Mirroring.
    Friday, September 19, 2008 7:56 PM
  •  Praveen Barath wrote:

    Error: 1418 - Microsoft SQL Server - The server network address can not be reached or does not exist. Check the network address name and reissue the command

    The server network endpoint did not respond because the specified server network address cannot be reached or does not exist.

    Fix/Workaround/Solution:

    Step 1) Your system Firewall should not block SQL Server port.

    Step 2) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Network Configuration
    Enable TCP/IP protocol. Make sure that SQL SERVER port is by Default 1433.

    Just to make sure follow one more step which may or may not be necessary.

    Step 3) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Client Configuration
    Enable TCP/IP protocol.



    I just have to call out to anyone reading this post that this workaround has absolutely nothing to do with the problem. Database Mirroring cannot be configured in any way from the SQL Server Network Configuration applet and is completely unrelated to port 1433. The topic quoted by Praveen refers to TCP TDS traffic and not to mirroring.

    The proper BOL topic is here: http://msdn.microsoft.com/en-us/library/aa337361.aspx
    Friday, September 19, 2008 8:02 PM
  • Hi Remus resanu,

     

    Thanks for making me correct,

     

    As far as error is concern 1418 ‘The server network address can not be reached or does not exist. Check the network address name and reissue the command states’.

    I feel it seems to be network issue and as he mentioned they are not in same domain.

    So I decided to give some points to check there is nothing about misguiding, this was just an assumption which might help.

     

    Question-

     

    Is it possible to establish database mirroring without opening ports 1433, 1434 on firewall and without enabling TCP/IP ports on two different domains i am keen to know.

     

    BR
    Praveen Barath

     

    Saturday, September 20, 2008 11:31 AM
    Answerer
  •  Praveen Barath wrote:

    Is it possible to establish database mirroring without opening ports 1433, 1434 on firewall  two different domains i am keen to know.



    Yes. Database mirroring only requires the port used by the DBM endpoint to be reachable (usually 5022). By 'reachable' I mean:
    - the host can be reached through IP (ie. ping)
    - port 5022 is not blocked by the firewall
    - IPSEC does not prevent the connection

    Domain membership is a different issue and is only relevant to authentication. If the two machines are in different domains then is not possible to establish a Windows based authentication and CERTIFICATE based authentication should be used instead (using symmetric accounts with same name and password does not count as true 'authentication' since its a hack).

    Port 1433 is only needed to connect through TDS to send T-SQL commands (ie. connect with a SQL client like SSMS). Port 1434 is only needed to browse for SQL instances if and only if the listenning port is different from 1433 and not known.

    Of course if port 1433 is closed then the statements needed to set up the mirroring (create the endpoint, exchange certificates, grant CONNECT permission, restore the database) cannot be executed remotly and must be executed localy. In particular that will prevent the DBM Wizard in SSMS to be able to establish a mirroring session. A true dba/sysadmin would never use the DBM Wizard from SSMS though.

     Praveen Barath wrote:

    and without enabling TCP/IP ports on


    You're going to have to explain what you mean by this. If you disable TCP/IP ports (ie. remove TCP as a protocol from the network stack) of course you cannot establish DBM session since its based on TCP. I'm pretty sure you didn't mean that, so please explain what you mean by this.


    Saturday, September 20, 2008 1:19 PM
  • Hi ,

     

    i am just relating my post with your suggestions,

     

    Praveen Barath wrote….

     

    Error: 1418 - Microsoft SQL Server - The server network address can not be reached or does not exist. Check the network address name and reissue the command

    The server network endpoint did not respond because the specified server network address cannot be reached or does not exist.

    Fix/Workaround/Solution:

    Step 1) Your system Firewall should not block SQL Server port.

    Step 2) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Network Configuration
    Enable TCP/IP protocol. Make sure that SQL SERVER port is by Default 1433.

     

    Remus Rusanu Wrote....

     

    Of course if port 1433 is closed then the statements needed to set up the mirroring (create the endpoint, exchange certificates, grant CONNECT permission, restore the database) cannot be executed remotly and must be executed localy. In particular that will prevent the DBM Wizard in SSMS to be able to establish a mirroring session. A true dba/sysadmin would never use the DBM Wizard from SSMS though.

     

     

    Praveen Barath wrote….

     

    Step 3) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Client Configuration
    Enable TCP/IP protocol.

    Remus Rusanu wrote..

     

    Remus Rusanu Wrote....

     

    If you disable TCP/IP ports (ie. remove TCP as a protocol from the network stack) of course you cannot establish DBM session since its based on TCP.

     

    P:S-  I am still learning, your post was really helpful so I would like to mark as HELPFUL.

     

    Thanks again for knowledge sharing if you suggest i can drop my post if you still feal it can mislead other readers or totally irrelivent.

     

     

    Saturday, September 20, 2008 2:22 PM
    Answerer
  •  Praveen Barath wrote:


    Thanks again for knowledge sharing if you suggest i can drop my post if you still feal it can mislead other readers or totally irrelivent.




    Yes, please do so.
    Saturday, September 20, 2008 2:29 PM
  • In case someone else comes across this thread....

    Make sure the domain accounts under which SQL Server runs have sufficient permissions on both servers.
    Wednesday, May 13, 2009 3:50 AM