locked
Cannot access sqlcesa35.dll RRS feed

  • Question

  • Hi 
    I have thouroughly looked for the entire forums already.
    But no one seem to be ran into a problem like mine.

    I used Configure Web Synchronization Wizard to create a virtual directory.
    I was able to access that directory by http://<mycomputername>/<directoryname/ and
    i can see sqlcesa35.dll as directory listing.
    When i clicked on dll file, IIS gave me 500-Internal Error.

    What is tha cause of this problem?
    Any suggestion?

    ps: I m running windows vista 64 bit and IIS 6.0 and SQL Server 2008
    Thanks in advance.
    Bo Bo
    Thursday, March 12, 2009 7:51 AM

Answers

  • When I set up a virtual directory using Web Synchronization Wizard, it showed me the actual path where that virtual diretory will go.
    The path is :
    C:\Program Files (x86)\Microsoft SQL Server Compact Edition\v3.5\sync\SQL\.

    But for IIS it has access only under c:\Inetpub\wwwroot.
    So I changed the path to C:\Inetpub\wwwroot and now i can access sqlcesa35.dll.

    What do u reckon, Erik?


    Thanks.
    Regards
    Bo Bo
    • Marked as answer by Bo Bo Lwin Monday, March 16, 2009 1:57 AM
    Friday, March 13, 2009 2:11 AM

All replies

  • Make sure to download and install the 3.5 SP1 server tools (SSCEServerTools-ENU-x64.msi) from here:
    http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=FA751DB3-7685-471B-AC31-F1B150422462&displaylang=en
    Erik Ejlskov Jensen, MCTS: WM App, MCITP: SQL 2008 Dev - http://erikej.blogspot.com Please mark as answer, if this was it.
    Thursday, March 12, 2009 11:14 AM
  • Thanks Erik. I will try it tomorrow morning as a first thing.
    But i thought after seeing some of ur posts in other threads, i have tried that option already too.
    Anyway I will try that again. The problem is i can access the directory but i cannot access the server agents dll.
    I will get back with the response tomorrow. Cos I ve got that error in my office computer.

    Thanks.
    Regards
    Bo Bo

    Thursday, March 12, 2009 2:47 PM
  • When I set up a virtual directory using Web Synchronization Wizard, it showed me the actual path where that virtual diretory will go.
    The path is :
    C:\Program Files (x86)\Microsoft SQL Server Compact Edition\v3.5\sync\SQL\.

    But for IIS it has access only under c:\Inetpub\wwwroot.
    So I changed the path to C:\Inetpub\wwwroot and now i can access sqlcesa35.dll.

    What do u reckon, Erik?


    Thanks.
    Regards
    Bo Bo
    • Marked as answer by Bo Bo Lwin Monday, March 16, 2009 1:57 AM
    Friday, March 13, 2009 2:11 AM
  • The path to program files should be OK, as the Web Sync Wizard does the requried setup tasks for you. Are you able to call sqlcesa35.dll on your server now?

    Erik Ejlskov Jensen, MCTS: WM App, MCITP: SQL 2008 Dev - http://erikej.blogspot.com Please mark as answer, if this was it.
    Friday, March 13, 2009 10:19 AM
  • Yes. Erik. I can access sqlcesa35.dll after changing directory to under inetpub/wwwroot.
     I doubt that web sync wizard set up the path because i was not able to access the predefined path before.

    Now I am able to test RDA push and pull methods as well although i m not so sure that changing the directory will affect somewhere else.

    Thanks
    Regards
    Bo Bo

    Friday, March 13, 2009 6:04 PM
  • Was your Error 500 message every time you went to access the sqlcesa35.dll file? or was it intermittent as in when you refreshed the page it worked fine, just not the first time round?

    was the only change you made from c to C in the properties for it?

    thanks

    Tris

    Tuesday, March 17, 2015 1:07 PM