none
Problem with install .net framework 3.5 on Vista RRS feed

  • Question

  • I find the following error when I try to install .net framework 3.5 on Windows Vista (my Windows Vista is newly installed on  a Virtual PC).

    [01/30/08,14:24:02] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 22
    [01/30/08,14:24:12] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

    Any idea on this error message?

    Wednesday, January 30, 2008 6:47 AM

Answers

  • Thank you.  In fact, I have successfully installed .Net framework 3.5 on my Vista after I installed all the Windows Update.  I am a bit disappointed on Vista when comparing with XP.  I can easily install .Net framework 3.5 on Windows XP but I need to install so many updates (I don't know which update help me to remove the error!) before I can install .Net framework 3.5!

    Thursday, January 31, 2008 9:31 AM

All replies

  • So could you please follow What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx for information?

     

    Thanks

    Thursday, January 31, 2008 8:13 AM
  • Thank you.  In fact, I have successfully installed .Net framework 3.5 on my Vista after I installed all the Windows Update.  I am a bit disappointed on Vista when comparing with XP.  I can easily install .Net framework 3.5 on Windows XP but I need to install so many updates (I don't know which update help me to remove the error!) before I can install .Net framework 3.5!

    Thursday, January 31, 2008 9:31 AM
  • I also had the same problem installing Microsoft .NET Framework v3.5 on Vista and the fix was to go to Control Panel ---> Programs and Features ---> Turn Windows features on and off ---> Microsoft .NET Framework v3.0 and select all of the following check boxes:

     

    • Windows Communication Foundation HTTP Activation
    • Windows Communication Foundation Non-HTTP Activation
    • XPS Viewer

     

    TimeFreedom

     

     pyeung wrote:

    Thank you.  In fact, I have successfully installed .Net framework 3.5 on my Vista after I installed all the Windows Update.  I am a bit disappointed on Vista when comparing with XP.  I can easily install .Net framework 3.5 on Windows XP but I need to install so many updates (I don't know which update help me to remove the error!) before I can install .Net framework 3.5!

    Friday, February 8, 2008 2:59 PM