none
compatibility between Window 7, classic ASP and Oracle 11g RRS feed

  • Question

  • hi,

    I must migrate a Web application written in ASP from a Windows 2003 Server machine to a Windows 7 Professional 64bit one. I installed Oracle 11.2.0.1.0 64bit Database and Oracle Data Access Components for Oracle Client (ODAC) 11.2.0.2.1  (32bit). Then, I configured my Web service so that it can run 32bit applications. But after several attempts, Im getting this error

    "3706: Provider cannot be found it may not be properly installed"

    this is my code

    <%
    On Error Resume Next 
    'option explicit
    
    Response.Clear() 
    
    
    Dim conOracle, OraSession
    Dim usr, OraDatabase
    
    Response.Buffer = true 
    
    usr = "username"
    Response.CharSet = "ISO-8859-1"
    
    Set conOracle = Server.CreateObject("ADODB.connection")
    ConOracle.Open ="Provider=ORAOLEDB.Oracle;Data Source=myDB;User ID=" & usr & ";Password=password"     'THIS IS WHERE ERROR OCCURS
    
    if Err.Number <> 0 then 
        Response.Clear() 
        response.Write "<hr>ORAOLEDB Error<br>" & err.number & "  --  " & err.Description & "<hr>"
        response.End
    else
        response.Write "ORAOLEDB. connection established"
    end if 
    
    set OraSession = Server.CreateObject("OracleInProcServer.XOraSession")  
    
    if Err.Number <> 0 then 
        Response.Clear() 
        response.Write "<hr>ORASESSION Error<br>" & err.number & "  --  " & err.Description & "<hr>"
        response.End
    else
        response.Write "Session created"
    end if 
    set OraDatabase = OraSession.dbOpenDatabase("myDB",usr & "/" & "password",cint(0))
    
    if Err.Number <> 0 then 
        Response.Clear() 
        response.Write "<hr>OPENDATABASE Error<br>" & err.number & "  --  " & err.Description & "<hr>"
    else 
        response.Write "database open"
    end if 
    %>
    
    

     

    I can assure you that Database and Oracle Drivers are correctly installed, and I can reach my Database, but when I try to set the ORAOLEDB driver, error raises.

    What can I do to resolve that issue? please help. thanks

    Tuesday, December 20, 2011 4:27 PM