none
USB 3.0 Problems with Kinect V2 RRS feed

  • Question

  • Hello To All,

         I recently purchased the Kinect V2 for Windows and have been unable to get it to function.  Here are my system specs.

         Dell XPS 17' 702X (year 2012), 2.7GHz., 16GB, NVIDIA, Renesas USB 3.0 ports (2), USB 2.0 ports (3), Win 8.1
         I receive the infamous warning that my USB doesn't have enough USB resources, etc.
         Playing around with the configuration, I no longer receive the USB resources error but, the Kinect flashes 3 red lights.
         I have a Renesas 3.0 chipset.  I am unsure if the USB 2.0 and USB 3.0 ports actually share the same controller.
         I have installed/uninstalled/reinstalled the Kinect 2.0 SDK several times.
         I have even REFORMATTED the PC with basic configuration and drivers only.
         I have also disconnected any other USB 2.0/3.0 keyboards, mice, etc.
         I have connected and reconnected all the cables and power adapters.
         I have tried to disable as many devices as possible.  The only device taking up bandwidth is the Bluetooth at 2%.

         The Windows Device Manager only picks up the Kinect V2's Microphone, but not the actual Kinect.
         It only picks up a Kinect V2 Interface or something similar.  It's like it doesn't see it at all.

         Unfortunately, I do not have a PCI express port so I cannot add an additional chipset controller/port.

         I think I read that DELL some Inspirons got the Kinect V2 to work.  I may be wrong.     

         I have absolutely NO idea why I can't get my Kinect to work on my PC.
         It either gives me the "Not enough resources error", or it flashes 3 red lights every 5 seconds.
         I have tried to find documentation on the 3 flashing red lights but have found nothing to date.

         1.  Would buying a USB Hub help or does it just end up splitting a signal from a single USB Hub?

         2.  If buyuing a USB Hub is the answer, are there any NON-PCI hubs that work with the Kinect V2?

         3.  Are there any system configurations I am forgetting to modify/disable?

         4.  Is it the Renesas chipset the problem?  How can I get information on the chipset itself to verify?

         5.  Although it says I have a Renesas Chipset, how can I verify this and are there any SPECIFIC drivers I should use?

         Can anybody please help me?  I have tried everything I can.

         Best Regards,

              Giovanni

    Monday, July 21, 2014 3:02 PM

All replies

  • I have the same laptop and can confirm there are some issues with the laptop that will not work with the SDK. The team is actively investigating. The issue is not with the sensor, but you may need to use another system.

    Carmine Sirignano - MSFT



    Monday, July 21, 2014 9:35 PM
  • Thanks Carmine.  Looks like I'll be returning the Kinect.  Sad though, the XPS 702 is a powerful PC.

    Saturday, July 26, 2014 4:26 PM
  • Hi Carmine,

    Been reading and finding many of these Kinect v2 USB issues, has the Renesas problem been resolved? Is there a fix anywhere? Is Mac support in the pipeline?

    Tried three different machines all with problems in SDK config verification. Managed to use openFrameworks workaround on one Lenovo laptop but still problematic for Native SDK functionality. Would really like to start getting two working together (on different machines). Great possibilities, horrible constraints.

    Thursday, April 16, 2015 8:50 AM
  • In the case of this XPS machine, it is a hardware issue and cannot be resolved with software. For Mac support(BootCamp), I have seen and used MacBook Pro and Air late 2013 editions and newer.

    See the troubleshooting thread for common issues and workarounds that can be used to mitigate common bandwidth issues off the USB3/PCIx bus: https://social.msdn.microsoft.com/Forums/en-US/20dbadae-dcee-406a-b66f-a182d76cea3b/troubleshooting-and-common-issues-guide?forum=kinectv2sdk


    Carmine Sirignano - MSFT

    Friday, April 17, 2015 11:31 PM
  • I have the same computer and I was actually able to use the Kinect v2 with windows 10 for a couple of days. It stopped working after some windows update. My other USB 3 peripherals work fine. Any news?

    Gabriel

    Saturday, December 12, 2015 8:44 PM