none
Installation of 3.5 Framework SP1 Failed on Windows Server 2003 Standard Edition x86 RRS feed

  • Question

  • Hi,

    Setup of .NET Framework 3.5 SP1 Failed on Development Server

    I found many discussions on the same topic, but nothing helped.

    Server Details: OS: Windows Server 2003 - Standard Edition - x86

    Available Frameworks in the Server: 

    1) .NET FRAMEWORK 1

    2) .NET FRAMEWORK 2

    3) .NET FRAMEWORK 2.0 SP2

    4) .NET FRAMEWORK 3.0 SP1

    4) .NET FRAMEWORK 3.5

    5) HOTFIX FOR .NET FRAMEWORK 3.5 (KB2418240)

    6) .NET FRAMEWORK 4 CLIENT PROFILE

    7) .NET FRAMEWORK 4 EXTENDED 

    Below is the screenshot of the Error Log File:

    [07/09/13,23:34:12] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [07/09/13,23:34:12] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [07/09/13,23:34:13] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [07/09/13,23:34:13] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [07/09/13,23:34:13] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [07/09/13,23:34:13] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [07/09/13,23:34:13] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [07/09/13,23:34:13] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [07/09/13,23:34:13] WapUI: [2] DepCheck indicates Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) is not installed.
    [07/09/13,23:34:13] WapUI: [2] DepCheck indicates XPSEPSC Installer was not attempted to be installed.
    [07/09/13,23:34:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.
    [07/09/13,23:34:13] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [07/10/13,00:57:10] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [07/10/13,00:57:51] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
    [07/10/13,01:21:48] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [07/10/13,01:22:24] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
    [07/10/13,01:28:30] Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86): [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [07/10/13,01:28:30] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [07/10/13,01:28:30] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [07/10/13,01:28:30] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [07/10/13,01:28:30] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [07/10/13,01:28:30] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [07/10/13,01:28:30] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [07/10/13,01:28:30] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed
    [07/10/13,01:28:30] WapUI: [2] DepCheck indicates Windows Installer Patch Registration Fix for .NET Framework 3.5 (x86) is not installed.
    [07/10/13,01:28:30] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 was not attempted to be installed.
    [07/10/13,01:28:31] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' was not attempted to be installed.
    [07/10/13,08:25:23] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [07/10/13,08:26:02] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.
    [07/10/13,09:56:49] Microsoft .NET Framework 3.0 SP2 x86: [2] Error: Installation failed for component Microsoft .NET Framework 3.0 SP2 x86. MSI returned error code 1603
    [07/10/13,09:57:31] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0 SP2 x86 is not installed.

    

    Friday, July 12, 2013 3:25 PM

All replies