none
Printing PDF to XPS cannot copy text RRS feed

  • Question

  • Dear all,

    Can anyone shed me light on why print a PDF (the PDF contains only Chinese characters) file to XPS that the resulting document the text is not able to copy. It happens only when the PDF contain Chinese characters on it. It seems printing a PDF (contains english text and number) are all copying ok. 

    Is it possible to make the printing of PDF (chinese document) to XPS and the output of XPS is able to copy-and-paste the text to notepad? Pleae advise. Thanks a lot.

    Sunday, June 10, 2012 2:58 PM

Answers

  • I think there's an option in Word to save text data too when "Publishing"as PDF/XPS. (Note: when you enable this, the saved file will be 2-3 times bigger than it was.)

    If the text data is not inside the PDF/XPS file, you cannot select them.

    Since you've mentioned "printing", if you print them through a PDF/XPS printer, try to see if you can find similar setting there. (For example, in on of the PDF printers, you have to change "PDF Settings" to "EBook" to force it include text data if it does not)

    EDIT: Just opened Word 2010 to confirm, when "Save as" to "PDF" format, there's option "Standard" which will include text data, and "Minimum" which will not save text data.

    And of course, there's protection setting for PDF which can prevent users from copy and paste data from the file.



    Monday, June 11, 2012 2:29 AM
    Answerer