locked
sending e-mail to active directory distribution group RRS feed

  • Question

  • User-77030870 posted

    Hello, I am trying to send an email to a distribution group in our active directory.  If I send the e-mail to a single address it works but when I try to access a distribution group it does not send at all.....then I added the line in bold below, and I get this error now:

    "Cannot get IIS pickup directory."
     
    Here is the code I am using:

                        ' Variable which will send the mail
                        Dim client As New SmtpClient("10.1.0.29")  <--- This is the IP address of our exchange server

                        client.DeliveryMethod = SmtpDeliveryMethod.PickupDirectoryFromIis

                          'set to and from
                        Dim Message As MailMessage = New MailMessage("Directory@something.com", "NewHire@something.com")

                        Message.CC.Add("PracticeGroupLeaders@something.com")
                        Message.CC.Add("AreaManagers@something.com")

                        With Message
                            'set body to html
                            .IsBodyHtml = True
                           

                            'Set body
                            .Body += "....body text......."
                     

                            .Subject = "...subject text......"

                        End With

                        'Send the message
                        client.Send(Message)

     Any help is appreciated.  I am hoping to get this fixed ASAP, hopefully today, but if not over the weekend by Monday.

     Thanks,

    Coty

    Friday, March 13, 2009 2:11 PM

Answers

  • User-77030870 posted

    Ok, I figured it out.  If anyone has this same problem, here is atleast what fixed it for me.  

    This is on exchange 2007. 

    Goto Exchange Management Console > Select Distribution Group > Properties > Mail Flow Settings > Message Delivery Restrictions > Properties > Uncheck the checkbox labelled, "Require that all senders are authenticated"

    Which should be ok because it's an internal distribution group on our intranet.

    Coty

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 3:32 PM

All replies

  • User-425639139 posted
    You distribution group has a mail address, that's what you need to add in the 'to' parameter.
    Friday, March 13, 2009 2:49 PM
  • User-425639139 posted
    Your distribution group has a mail address, that's what you need to add in the 'to' parameter.
    Friday, March 13, 2009 2:49 PM
  • User-77030870 posted

    I am using the correct e-mail address associated with the distribution group so that is not it.

    Friday, March 13, 2009 4:38 PM
  • User-77030870 posted

    Ok, I figured it out.  If anyone has this same problem, here is atleast what fixed it for me.  

    This is on exchange 2007. 

    Goto Exchange Management Console > Select Distribution Group > Properties > Mail Flow Settings > Message Delivery Restrictions > Properties > Uncheck the checkbox labelled, "Require that all senders are authenticated"

    Which should be ok because it's an internal distribution group on our intranet.

    Coty

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, March 14, 2009 3:32 PM