locked
How do I include java applet code RRS feed

  • Question

  • User155697438 posted
    I 'think' I am in the right forum. Please forgive if not. I am trying to include the following applet code to include on a website: <applet code="NCMECbanner.class" codebase="http://banner.missingkids.com/java/" align="baseline" hspace="8" width="342" height="128" VIEWASTEXT> </applet> The code works inside the development environment but when I compile and view the code locally, the code doesn't work. When viewing the sourcecode, the code just isn't there between the tags. I am sure that I'm not including something...did a little search on SymLanguageType but the document is ambiguous. Any help would be greatly appreciated. Schleyer
    Monday, March 1, 2004 12:42 PM

All replies

  • User-1391363652 posted
    Interestingly enough, when I pulled up this post in a news reader (SharpReader) the applet displayed just fine. I created a brand new page and simply pasted your code and ran the page---the applet worked again. Can you provide some code to see how you're placing it on a page? Theoretically, VS.NET shouldn't touch your <applet> declaration since it's not a server control.
    Monday, March 1, 2004 11:59 PM
  • User155697438 posted
    ALL I DID WAS INSERT THE APPLET CODE INTO A USER CONTROL <%@ Control Language="vb" AutoEventWireup="false" Codebehind="missingchildren.ascx.vb" Inherits="CSPD.missingchildren" TargetSchema="http://schemas.microsoft.com/intellisense/ie5" %> <applet code="NCMECbanner.class" codebase="http://banner.missingkids.com/java/" align="baseline" hspace="8" width="342" height="128" VIEWASTEXT> </applet> AND THEN INSERTED INTO ANOTHER USER CONTROL LIKE THIS: <%@ Control Language="vb" AutoEventWireup="false" Codebehind="namebanner.ascx.vb" Inherits="CSPD.namebanner" TargetSchema="http://schemas.microsoft.com/intellisense/ie5" %>
    <asp:hyperlink id="hyperlink2" runat="server" cssClass="NameUnSelected" NavigateUrl="../pagesadmin.aspx">WHATEVER</asp:hyperlink> <applet code="NCMECbanner.class" codebase="http://banner.missingkids.com/java/" align="baseline" hspace="8" width="342" height="128" VIEWASTEXT> </applet>
    THIS LAST USER CONTROL IS USED ON A DEFAULT PAGE WITH THIS CODE: <uc1:namebanner id="Namebanner1" Runat="server"></uc1:namebanner> LIKE I SAID IN PREVIOUS POST...IT WORKS FINE INSIDE MY DEVELOPMENT ENVIRONMENT (VS.NET) BUT AFTER COMPILE AND RUN IN BROWSER...IT DOESN'T SHOW...I TRIED RESETTING SOME BROWSER SETTINGS TO NO AVAIL. THANKS FOR INTEREST...STILL STRUGGLING Schleyer
    Tuesday, March 2, 2004 11:08 AM
  • User-1391363652 posted
    Very strange. I once again created pages with your code and everything works (literally pasted your code). I created a user control called namebanner.ascx and put in on a blank page, default.aspx. I've uploaded both the page and the control to my server. Does this page work for you? Does anything at all show in place of the applet?
    Tuesday, March 2, 2004 3:30 PM
  • User155697438 posted
    NO...do you think it might be a firewall issue...I'm running Norton Internet Security?
    Wednesday, March 3, 2004 7:50 AM
  • User155697438 posted
    That's what is was...I turned off my ad blocking and tested...thanks for helping test this!!! Schleyer
    Wednesday, March 3, 2004 7:52 AM