locked
Is .Net Standard version associated with Xamarin.Android's Target Framework? RRS feed

  • Question

  • User303504 posted

    Hi,

    I'm using .Net Standard 2.0 for our Xamarin.Forms application. The application should be able to run on Android 6.0 or higher. Now the table related to .Net Standard versions, shows that in order to use .Net Standard 2.0, you would need to use Xamarin.Android 8.0. But is that the Target Framework or the Minimum Android version? i.e. How can I use .Net Standard 2.0 and force the application to also be able to run on Android 6.0?

    Sunday, May 20, 2018 1:07 PM

All replies

  • User327754 posted

    When choosing a .NET Standard version, you should consider this trade-off:

    The higher the version, the more APIs are available to you. The lower the version, the more platforms implement it.

    This is target version not minimum android version i think you can test .Net Standard 2.0 also on android 6.0.

    Monday, May 21, 2018 6:32 AM