none
Trailing Zero error in BizTalk 2010 - Inbound processing RRS feed

  • Question

  •  

    Hello,

     

    I am trying to process an inbound 810. I have come to realize that when my IT104 has trailing zeros, validation fails. I have made changes to my X12 settings to allow for trailing zeros for the 810.

    Error: 1 (Field level error)

    SegmentID: IT1

    Position in TS: 7

    Data Element ID: IT104

    Position in Segment: 4

    Data Value: 51.00

    6: Invalid character in data element

    My data looks like this IT1*1*50*EA*51.00**PN*415TTZZ8

    If I change the 51.00 to 51.23 of course it works. I am not doing any batching.

    Any suggestions?

     

    Dylan

    Wednesday, December 14, 2011 10:03 PM

Answers

  • I had this error earlier this week.  Have to change the agreement Transaction set Settings. Validation Allow leading and trailing zeros and spaces.

     

    See if that works.

     

    Thanks,

    Mike

    • Marked as answer by DjHall Wednesday, December 21, 2011 6:42 PM
    Thursday, December 15, 2011 12:19 AM

All replies

  • I had this error earlier this week.  Have to change the agreement Transaction set Settings. Validation Allow leading and trailing zeros and spaces.

     

    See if that works.

     

    Thanks,

    Mike

    • Marked as answer by DjHall Wednesday, December 21, 2011 6:42 PM
    Thursday, December 15, 2011 12:19 AM
  • Try removing the decimal points from 51.00. Then it will work. You can use round functoid so that the value will be 51
    Thursday, December 15, 2011 9:18 PM
  • Hello Mike,

     

    I have tried that. The only way I got the error to stop was to change EdiDataValidation=False in the Disassemble of the EDI Pipeline Component. This is not what want to do. It is fine for now but I am still looking for a better solution.

     

    Dylan

    Monday, December 19, 2011 6:31 PM
  • Hello Mike,

    I looked at my configuration again and realized that although I changed my settings for trailing zeros I had not set the X12 identities correctly. I was using test data with slightly different ISA/GS values... anyway now it works!

    Thanks

    Dylan

    Wednesday, December 21, 2011 6:48 PM