how can i config permission for wwwroot foler? RRS feed

  • Question

  • User-410495528 posted

    this is my classic asp code :

    StartURL = "www.google.com"
    set IE = CreateObject("InternetExplorer.Application")
    IE.Visible = true
    IE.Navigate StartURL

    when i run in iis 7.5 and windows 7

    ,then give me a response:

    Microsoft VBScript runtime error error '800a0046'
    No permission:'CreateObject'
    /1.asp, line 3

    Friday, January 1, 2021 6:37 AM

All replies

  • User-848649084 posted


    The reason behind the error is insufficient permission to the folder which page you are trying to access.

    To resolve the issue you can follow the below steps:

    1)Right-click on the site folder which you are trying to access.

    2)Select properties->Security tab

    3)Click on the edit button-> add

    Add iis_iusrs and iusr permission to full control.

    Restart iis server after doing changes.

    Make sure you have enabled the anonymous authentication in iis and the rest of the are disabled.

    you could also set the application pool identity to the custom user whose role is the administrator.



    Friday, January 1, 2021 8:33 AM
  • User-813905534 posted

    By default wwwroot (the root directory of ASP) is in the c drive. Since it's your system drive, the default permission to save or read files from this location is prohibited. You may change the default permission, however it's not recommend instead use a new Virtual directory. I have demonstrated both about changing the default permission or using virtual directory in this video https://youtu.be/5nlZeIYasMI

    Watch to know more in detail. Please let me know if you still face any error.

    Sunday, April 18, 2021 3:40 AM