none
Unable to Activate Publishing Infrastructure Feature in Site collection of SharePoint 2013

    Question

  • Hi,

    we have Migrated from SharePoint 2010 to SharePoint 2013 on premises, when Activating  Publishing Infrastructure Feature in Site collection , get the following error

    A duplicate field name "PublishingCacheEnabled" was found.

    Where do I find this feature ? can some one let me know how to remove this field name ? Thanks...

    Wednesday, August 14, 2013 7:33 PM

Answers

  • You can use SharePoint manager 2013 to check whether is a field "PublishingCacheEnabled" is available or not, then you can delete using SPM as well.

    http://spm.codeplex.com/

    Are you able to activate the feature using Force command?

    $siteUrl = "http://sharepoint-journey.com/"
    $siteCollection = Get-SPSite $siteUrl
    Enable-SPFeature "PublishingSite" -Url $siteCollection.Url -force


    My Blog- http://www.sharepoint-journey.com| Twitter
    If a post answers your question, please click "Mark As Answer" on that post and "Vote as Helpful

    • Marked as answer by Jyo Bana Thursday, August 15, 2013 2:37 PM
    Thursday, August 15, 2013 4:08 AM
    Moderator

All replies

  • Is this a true statement - is there a site field on the site collection with this name already? Can you start with a new site collection you just created and try again? Could this field have gotten onto your site collection without publishing by some kind of WSP deployment or Content Type hub? Some third party data-moving tools like DocAve or MetaLogix or ControlPoint move more information than they are supposed to like site fields, etc...

    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    Wednesday, August 14, 2013 7:46 PM
  • Hi,

    Goto Site Settings -> Site Columns. Check if a site column by the name "PublishingCacheEnabled" exists in the list. If yes, click on it and delete it. If not able to find it that way, use the following powershell to delete it.

    $web = Get-SPWeb Site url 
    $list = $web.Fields["Field Name"]
    $field.AllowDeletion = $true
    $field.Sealed = $false 
    $field.ReadOnlyField = $false
    $field.Hidden = $false
    $field.Delete() 
    $web.Update() 

    Then, try to activate the Publishing Infrastructure feature.

    Narahari

    ******If a post answers/helps your question, please click "Mark As Answer" on that post and/or "Vote as Helpful*******

    Thursday, August 15, 2013 2:36 AM
  • You can use SharePoint manager 2013 to check whether is a field "PublishingCacheEnabled" is available or not, then you can delete using SPM as well.

    http://spm.codeplex.com/

    Are you able to activate the feature using Force command?

    $siteUrl = "http://sharepoint-journey.com/"
    $siteCollection = Get-SPSite $siteUrl
    Enable-SPFeature "PublishingSite" -Url $siteCollection.Url -force


    My Blog- http://www.sharepoint-journey.com| Twitter
    If a post answers your question, please click "Mark As Answer" on that post and "Vote as Helpful

    • Marked as answer by Jyo Bana Thursday, August 15, 2013 2:37 PM
    Thursday, August 15, 2013 4:08 AM
    Moderator
  • Hi,

    This script does not run , after reading $field.AllowDeletion = $true, it fails saying Property 'Allow Deletion' cannot be found on this object : make sure it exists and settable


    Thursday, August 15, 2013 1:42 PM
  • Can you try to delete this field using the UI by going to Site Settings -> Site columns? Is this the only publishing field that already exists or are there others?

    Please mark my response as an answer if appropriate.
    Learn.SharePoint.com

    Thursday, August 15, 2013 1:56 PM
  • Hi Devendra, perfect...tried via the Force Command....it works ! able to activate the Publishing Feature

    Activate Site Collection Level
    Enable-SPFeature -Identity PublishingSite -URL http:// -Force
    Activate Site Level
    Enable-SPFeature -Identity PublishingWeb -URL http:// -Force

    Thursday, August 15, 2013 2:37 PM