none
error retrieving information from user datastore

    Question

  • hello guys,

    i am writing a pocket pc project using vb.net 2005. just this morning i opened up my project
    and I got the following error..

    error retrieving information from user datastore.

    and then

    "the project could not be opened because it refers to a device platform that
    does not exist in your datastore."

    I haver been unsuccessful at fixing this problem.

    so far I have tried

    deleting the contents of the Corecon directory in both the
    user store and the all user store as outlined
    http://msdn2.microsoft.com/en-us/library/ms184403.aspx

    i have also tried re-installing the program
    and re-installing the windows mobile 5.0 sdk and the ppc 2003 sdk still with
    no luck..

    I am at a lost as to what to do. i have lost a whole days work on this problem :(

    Could someone shed some light please.

    thanks very much!!

    Nathan
    Monday, May 22, 2006 9:02 PM

Answers

All replies

  • Uninstalling and reinstalling WM 5.0 should work. You might find this post helpful http://www.danielmoth.com/Blog/2006/04/device-platform-not-found.html.
    Friday, May 26, 2006 8:27 AM
  • Hello,

    Thanks for your reply! I unfortunatley have tried that to no avail. Im not sure what else to do... No-one seems to know the answer...

    any other ideas

    Friday, May 26, 2006 12:09 PM
  • i have managed to sort this problem out...

    I followed these instructions http://support.microsoft.com/?kbid=907965 and then did a complete re-install.

    Nathan

    Monday, May 29, 2006 10:11 PM
  • I am experiencing the same, very frustrating problem.  Next time, do some quality assurance guys!
    Tuesday, November 14, 2006 3:31 AM
  • In regards to the the Windows Mobile 5.0 SDK examples that give the error "Error retrieving information user datastore.   Platform not found."

    I created new Windows Mobile 5.0 projects... and then brought in the example SDK code. 

    The issue is resolved for me.
    Friday, May 25, 2007 3:57 PM
  • Reinstallation of WM5 SDK + ActiveSync resolved my problem.

     

    Regards,

    Mariouche

    Monday, July 02, 2007 2:57 PM
  • None of the above solved my problem, but this did:
    http://forums.asp.net/t/1068947.aspx

    Just uncheck the T-SQL-box when attaching to the process.
    Wednesday, July 25, 2007 7:14 AM
  • This error occurs when the datastore has become corrupt. To re-create the datastore, you should delete the datastore and reopen a solution along the lines of the following steps.

    Caution noteCaution

    This process deletes any custom items you have added to your datastore, such as devices copied from an existing device, emulator configuration properties, and so on.

    To delete your datastore and reopen the solution

    1. Save your work, and then close any remote tools and Visual Studio.

    2. Delete the entire contents of the Corecon directory.

      This directory is located under %USERPROFILE%\Local Settings\Application Data\Microsoft.

      For example, del Documents and Settings\myname\Local Settings\Application Data\Microsoft\Corecon\*.*.

    3. Re-open Visual Studio.

      A new datastore has been created.

    Wednesday, June 10, 2009 5:46 AM
  • I have the same problem, but only with one project, the other projects seem to work.  Is there something specific in the project that might be doing this?
    There is 10 types of people in the world, those that understand binary, and those that don't.
    Thursday, June 11, 2009 7:59 PM
  • Hi,

    Please try this method (May be in first sight seems strange, but it works!!!)

    Save your work, and then close all remote tools and Visual Studio.

    Goto Corecon directory.

    This directory is located under %LOCALAPPDATA%\Microsoft\CoreCon. ( <tt>Documents and Settings\Useraccount \Local Settings\Application Data\Microsoft\Corecon\*.* </tt>

    Rename it or take a backup.

    Copy Corecon directory from some body else’s environment.

    Now try to start the Platform builder.

    Hope it worked!!! :)

     

    ~

    AnvikSingh

    Wednesday, February 03, 2010 4:35 AM
  • Hi,

     

    the delete of the 'corecon' directory worked for me, even though i had done the reinstall of both wm5/6 sdk's.

     

    Regards

     

    Mark

    Wednesday, July 07, 2010 1:19 PM
  •  

    Hi,

    The folder location is like this on vista:

     

    users\youruser\appdata\local\microsoft\corecon

     

    Regards

     

    Mark

    Wednesday, July 07, 2010 1:22 PM
  • Hi, I was testing and at the end I found the solution by installing the following SDK.

    http://www.microsoft.com/downloads/details.aspx?familyid=83a52af2-f524-4ec5-9155-717cbe5d25ed&displaylang=en

    I'm Happy.

    Regards,

    Tulio

     


    VS 2005
    Sunday, August 29, 2010 12:35 AM