none
Help Viewer 1.1 fails unless I disconnect the internet connection RRS feed

  • Question

  • I am using Microsoft Help Viewer 1.1 launched from Visual C# 2010 Express on a Windows 7 Professional system.  The complete set of help files appears to be downloaded. 

    For several months the Help Viewer worked well and I had no complaints.  Then the router died and my new router believes that it is IPv6 compatible, but my internet service provider has no DNS service for IPv6.  The only internet providers that will service my area are all satellite. 

    From that day forward, Help Viewer has complained that "This program cannot display the webpage" on a TabPage labeled "Internet Explorer cannot display th..." from my home.  However, Help View does work as expected if I do one of two things, 1) either disconnect from my LAN and the internet, or 2) take my laptop to a location that has a WiFi that uses an AT&T DSL connection to the internet. 

    I am new to your forum, and may have stumbled into the wrong place to ask for help.  The "feedback" option of Help Viewer is blocked too.

    Saturday, June 9, 2012 3:36 AM

All replies

  • Either the same problem, or one masquerading as the same problem appeared with the use of the Windows Help and Support program launched from explorer.exe and any number of other system programs from the menu item Help -> View Help.  As opposed to the Microsoft Help Viewer 1.1, Windows Help and Support worked OK with Offline Help, but could not find the web site it wanted while using Online Help.

    A "fix of sorts" was accidentally discovered when I inserted the IPv4 addresses for the Google DNS into my router setup page.  Both flavors of the Help programs are now seemly happy.  Of course, there is strong evidence that I have simply side-stepped the underlying problem or moved the the issue into the bow-wave for some later rediscovery.  There was some reluctance on my part to believe that the problem is really gone, so I have waited several days before making this addendum. 

    The most recent power up boot claimed that something over 20,000 changes had been done with 13 updates so I am unsure as to the status of any of the IPv6 issues.  My service provider still has no intent to provide the upgrades necessary to move into IPv6, but it appears that Windows took the presence of an IPv6 router as decision to not try an IPv4 site if the IPv6 address is unreachable.  Under no circumstances could I be considered an IP expert, so all I can do is sift though the clues that I can uncover.  Almost none of the statements made her can be tested and certified with what I know or the resources available to me, but I did flip back to the default DNS in the router setup to prove that I could switch the symptom on and off.


    Cliff

    Friday, June 15, 2012 7:36 PM