locked
Visual Studio 2012 RC Ultimate - AV trying to run Graphics Diagnostics with MarbleMaze sample

    Question

  • Hi - I am trying to checkout the Graphics Diagnostics tool with VS 2012 RC on Win8 32-bit build 8400.  I tried the XAML DirectX 3D shooting game sample and DirectX Marble Maze game sample from code.msdn.com. When I start graphics diagnostics, both samples give access violation in  in VsGraphicsHelper.dll.  I tried three different systems - with different GPU Intel HD Graphics and NVIDIA GeForce GTX 560 Ti.  Is anyone else running into this with  VS 2012  RC graphics diagnostics, if so any workarounds? The callstack at AV is:

    VsGraphicsHelper.dll!CHookMgr::AddToRefList(struct CHookRefListNode * *,class CHookedObject *) Unknown
      VsGraphicsHelper.dll!CHookedObjectGeneric::RememberThing(class CHookedObjectGeneric * *,class CHookedObjectGeneric *) Unknown
      VsGraphicsHelper.dll!CD3D11DeviceState::RememberThing(void * *,void *) Unknown
      VsGraphicsHelper.dll!ObjectIntArray11<class CHookedID3D11ShaderResourceView *,128,0>::Set(unsigned int,unsigned int,class CHookedID3D11ShaderResourceView * *,unsigned int,int) Unknown
      VsGraphicsHelper.dll!CHookedID3D11DeviceContext::PSSetShaderResources(unsigned int,unsigned int,struct ID3D11ShaderResourceView * const *) Unknown
      VsGraphicsHelper.dll!CSpyHookedID3D11DeviceContext::PSSetShaderResources(unsigned int,unsigned int,struct ID3D11ShaderResourceView * const *) Unknown
      MarbleMaze.exe!SDKMesh::RenderMesh(unsigned int meshIndex, bool adjacent, ID3D11DeviceContext * d3dContext, unsigned int diffuseSlot, unsigned int normalSlot, unsigned int specularSlot) Line 577 C++

    Thursday, June 7, 2012 7:35 PM

All replies

  • Hello,

     

    Thanks for your feedback, I will involve more experts to investigate it.

     

    Best regards,

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, June 8, 2012 6:24 AM
    Moderator
  • I tried to run dxdiag and the sample application on Win8 64-bit platform. But I can't reproduce your problem. Is the problem spcific for 32bit version. Or you can share the repro steps for me.

    Best Regards,
    Han Xia

    Tuesday, June 19, 2012 2:59 AM