locked
Load / Response Time between the default NewForm.aspx and a Customised "NewForm.aspx" RRS feed

  • Question

  • Hi All,

    There has been something that has been irking me for quite some time. At the moment I have a list which I only want the user to be able to edit certain fields the other fields are populated via Workflow depending on what they select etc. 

    Now if I make the default "New" form as the original NewForm.aspx (which will list all questions) the form will load within 1 second, but if I change the default to my NewForm2.aspx with the other columns taken out it will take anywhere between 8-10 seconds until the screen even begins to respond. So the user is left there wondering if they have clicked the button or not.

     

    Can anyone explain to me why this happens? How we can alleviate this?

    We are currently using WSS3.0 SP2

    Regards,

    Ian

    Wednesday, August 10, 2011 1:28 AM

Answers

  • Hi Ian,

    So we have response time for all customized and default pages.

    Also please check the statics in session view.

    It will give you report of each hit and so you can check from which point page started delay to load.

    And after getting that point try to minimize the customization or modify the code so that it will load normally.

    As per my knowledge normally customized page takes a little long time to load as compared with default page.   


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Wednesday, August 10, 2011 9:56 AM

All replies

  • Hi Ian,

    Is there any customized content on NewForm2.aspx ?

    use Fiddler to debug the page load process.

    Fiddler will tell you on which part of page it takes long time to load.

    Compare page load times of newform.aspx and newform2.aspx from fiddler traces.

    You can download it from - http://www.fiddler2.com/fiddler2/


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Wednesday, August 10, 2011 4:37 AM
  • Hi Pratik,

    Originally I had thought that it might be the customised content / jQuery etc. so i created 2 forms so in fact I have 3

    • The Original NewForm.aspx - which does a server call to load all fields in the list
    • NewRequest.aspx - Minimal Fields which require USER input. also contains customised content / jQuery - Help Icons / collapsable fields.
    • NewForm2.aspx - Only contains minimal fields which require USER input.

    Load times for the above.

    • NewForm.aspx - 0.5secs
    • NewForm2.aspx - 10 secs
    • NewRequest.aspx - 12.5secs

    It appears as though the server receives the request sits on it for that elapsed time when it finally sends a response it's almost instant. Is this a server or user issue?

    Appreciate the help / Fiddler is an amazing program.

    Regards,

    Ian

     

    Wednesday, August 10, 2011 7:04 AM
  • Hi Ian,

    So we have response time for all customized and default pages.

    Also please check the statics in session view.

    It will give you report of each hit and so you can check from which point page started delay to load.

    And after getting that point try to minimize the customization or modify the code so that it will load normally.

    As per my knowledge normally customized page takes a little long time to load as compared with default page.   


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Wednesday, August 10, 2011 9:56 AM