none
SSDT BI 2015 - cannot open BIML-generated packages

    Question

  • Whenever I try to open SSIS packages that were generated automatically using BIML the Visual Studio reports the following error. 

    Error loading 'FileName.dtsx' : The package failed to load due to error 0xC0010014 "One or more error occurred. There should be more specific errors preceding this one that explains the details of the errors. This message is used as a return value from functions that encounter errors.". This occurs when CPackage::LoadFromXML fails.

    I tried changing the project degugging option - RunIn64BitRuntime from true to false and modifying regional settings for date formatting. Neither worked.

    I have installed the BIDS Helper add-in for Visual Studio 2015 but it didn't help. The problem shouldn't be related to the fact that the package was generated by BIML. All DTSX files are the same and it doesn't matter if it was created manually using Visual Studio or automatically by a third party app.

    I am using Visual Studio 2015 Professional with SQL Server Data Tools for VS2015 on Windows 10 x64.

    Wednesday, July 20, 2016 10:40 AM

All replies

  • Hi Łukasz Kastelik,

    According to your description, the SSIS packages that could not opened with Visual Studio is generated by BIML and if the SSIS packages generated by Visual Studio and other third part app, it can be opened by Visual Studio correctly.

    I think the problem should be related to the SSIS packages that generated by BIML. Please upload a sample SSIS packages that generated by BIML to OneDrive and share a public link here. I will try it in my side to check whether this problem caused by the generated packages or Visual Studio itself.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, July 21, 2016 6:23 AM
    Moderator
  • Did you ever get this resolved? We are facing the same issue where packages that got generated via biml in ssdt 2012 are unable to open in visual studio 2015.
    Tuesday, February 21, 2017 1:35 PM