none
Enabling Classic ASP on Azure instances running on Windows Server 2008 R2 IIS7.5 RRS feed

  • Question

  • I hope  I'm asking this question in the correct sub-forum.

    How can I (say manually) set to enable Classic ASP pages browsable for my website that is deployed on a Azure instance whereby its OS allocated is Windows Server 2008 R2, with IIS 7.5

    I got a 404 File or directory not found when I browse to a simple classic ASP (that will response.write hello world).

    Also, if need to install classic ASP on the Azure instance server on startup, how do I do with with a startup script??

    Thanks.

    Tuesday, August 7, 2012 2:50 AM

Answers

All replies

  • See http://things.smarx.com/#Enable Classic ASP.

    I think there may also be a sample in the Windows Azure Platform Training Kit, but I don't remember for sure.

    • Marked as answer by FbLover2011 Wednesday, August 8, 2012 1:08 AM
    Tuesday, August 7, 2012 3:39 AM
  • If you are asking about running running asp on webrole, you can find detailed steps here. It's not different way than Steve posted. but it has some detailed steps.

    If you are using azure web sites you can host class asp sites there also. Go through this video to understand the capabilities of azure web sites.

    If you are using Azure VM to configure your web sites, it is very simple IIS7 configuration. Just go through this documentation

    I believe your problem fall in to first option as you are specifically asking for start up tasks.



    Please mark the replies as Answered if they help and Vote if you found them helpful.

    Tuesday, August 7, 2012 4:54 AM
  • Hi Steve,

    After I've tried the steps (by referring to the link provided), I've re-deployed the package to my hosted service.

    I tried browsing to any classic asp page and now I got a 500 Internal server error.

    I tried browsing to any .NET page and I don't get any server error.

    Am I missing something in the web.config?

    Thanks.

    Tuesday, August 7, 2012 5:26 AM
  • It is probably because of your application error. Can you enable RDP for your web role and see if you have any errors in the event log?


    Please mark the replies as Answered if they help and Vote if you found them helpful.

    Tuesday, August 7, 2012 5:40 AM
  • Hi Veerendra,

    I've followed the instructions and steps from Richard's blog (the link you provided).

    It is the same steps that I did, created a startup.cmd, have just one line

    start /w pkgmgr /iu:IIS-ASP

    saved as ANSI, add in startup tag to ServiceDefinition.csdef file exactly, and also changed Copy to Output Directory from Do no copy to Copy if newer.

    Re-package, re-deployed to my hosted service, still it didn't work.

    My web.config for my webrole is as simple as

    <?xml version="1.0" encoding="utf-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <connectionStrings/>
      <system.web>
        <compilation debug="true" targetFramework="4.0" />
        <authentication mode="None"/>
      </system.web>
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true" />
      </system.webServer>
    </configuration>

    I believe I'm missing something but I'm not sure what it is.

    Thanks

    Tuesday, August 7, 2012 5:45 AM
  • Hi Veerendra,

    I've RDP to my webrole, I've checked the on the following

    Event Viewer -> Windows Logs -> Application

    Event Viewer -> Windows Logs -> Security

    Event Viewer -> Windows Logs -> Setup

    Event Viewer -> Windows Logs -> System

    Event Viewer -> Windows Logs -> Forwarded  Events,

    there is nothing to indicate the error. I tried browsing the windows logs immediately I browse to a classic asp page that gives me the 500 internal server error.

    Nothing new turns up.

    As I mentioned, I can browse .NET pages like .aspx without hitting any error. ONLY pages with .asp will give me the 500 internal server error.

    Could the fault lies within my web.config?

    Tuesday, August 7, 2012 6:25 AM
  • Hi,

    I think you can use Remote Desktop to connect Azure VM to see if it's works fine in VM local, and you can also install some ASP debugging tools in Azure VM, 500 error always means the application internal error.

    BR,

    Arwind


    Please mark the replies as answers if they help or unmark if not. If you have any feedback about my replies, please contact msdnmg@microsoft.com Microsoft One Code Framework

    Tuesday, August 7, 2012 7:26 AM
    Moderator
  • Hi Arwind,

    Thanks for the suggestion. Upon further inspection, there are indeed some error in the ASP code.

    It has been fixed.

    Thanks.

    Wednesday, August 8, 2012 1:07 AM