locked
Creating a setup wizard-> Files are not installed under selected installation path RRS feed

  • Question

  • Hi!

    I have added a Setup Wizard project to my solution. And all the necessary files are included.

    the installer works fine and the program runs accordingly BUT the installer seems to ignore the installation path. Instead the installer just installs all files directly under C:

    In the Setup Wizard i have set DefaultLocation of the Application Folder to [ProgramFilesFolder][Manufacturer]\[ProductName] (which is default i think)

    BUT the installer seems to ignore it.....

    What can I have done wrong??

    • Moved by CoolDadTx Friday, June 8, 2012 1:57 PM Setup related (From:Visual C# General)
    Friday, June 8, 2012 6:44 AM

All replies

  • hi

    did you try to rebuild the setup project specifically ? if you build the solution it does not seem to build the setup by default... (you can change that in the solution configuration)

    And the "[ProgramFilesFolder][Manufacturer]\[ProductName]" seems to be good i've the same one...


    Friday, June 8, 2012 11:59 AM
  • Yes I have rebuild the setup project! First the solution and then the setup project... Still the same result :(
    Friday, June 8, 2012 12:43 PM
  • Is it the first installer you create on your machine ?

    can you copy the project file ?

    Friday, June 8, 2012 1:47 PM
  • Is it the first installer you create on your machine ?

    can you copy the project file ?

    Yes its the first installer I create on the machine...

    What do you mean by "can you copy the project file"?

    Monday, June 11, 2012 4:57 AM
  • Hi Tobias,

    Could you please create a install log and post it here?

    Do you have the admin permission/

    You can create a install log by using msiexec command: msiexec.exe /i "<msi path>" /l*v "<log path>". For more details, see http://msdn.microsoft.com/en-us/library/windows/desktop/aa367988(v=vs.85).aspx.

    In addition, I suggest you read the link below and check if Phi's suggestion works for you.

    http://social.msdn.microsoft.com/Forums/is/winformssetup/thread/36036c55-2b64-4026-8ecc-39a251807273

    Please let us know the result.

    Best Regards,


    Bob Wu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Bob Wu-MT Friday, July 6, 2012 9:28 AM
    • Unmarked as answer by Bob Wu-MT Friday, July 6, 2012 9:28 AM
    Monday, June 11, 2012 9:24 AM