none
Attack Surface Analyzer Tool fails to generate Attack Surface Report RRS feed

  • Question

  • Hi All,

    Our product is failing the Windows Logo Certification under the Attack Surface Analyzer(ASA) test case.

    Hence, we ran the Attack Surface Analyzer tool against our product. We obtained the ASA's msi from http://www.microsoft.com/en-in/download/details.aspx?id=24487.

    We used a Windows 7 OS and also installed the .NET framework 4.0.

    We followed the steps under "Collecting attack surface information with .NET Framework 4 installed".

    1) Downloaded and installed ASA on a fresh Windows7 OS machine with the .NET framework 4.0 installed in it.

    2) Ran ASA from the Start menu and chose to run the baseline scan. BaseLine CAB was generated successfully.

    3) Installed our product and ran the application.

    4) Ran ASA from the Start menu and chose to run the productLine scan. ProductLine CAB was also generated successfully.

    5) Ran ASA from Start menu and chose to generate the Attack Surface Report.

    6) Next, we get an alert saying that the tool is running the analysis and loading the product CAB.

    7) The tool then fails to load the product CAB and shows the following error:

    ASA Fails to Parse Product CAB file

    NOTE: We didn't change the name prompted by the tool for the above CAB reports the first time. Due to failure, we also tried to rename the CAB file names to simpler ones. But alas, we get the same error.

    Are we missing something here? What could be the solution to this issue?

    Thanks,

    Supreet Bhaskar



    Thursday, June 20, 2013 5:06 AM

All replies