locked
AsyncPostBack Trigger Chrome RRS feed

  • Question

  • User-1835835255 posted

    I have a radio button that has Async Postback.

    When you click rbTomorrow radiobutton the async postback doesn't work in chrome

    The functionality works in Safari, Firefox and IE. but the Async Postback doesn't work in chrome (production).  In my development environment the Async Postback works in Chrome but on production server it doesn't work.  I have hosting through godaddy.

    Web.config is the same in development environment and production except for the connection strings.

    It might have something to do with the radiobuttons being in an updatepanel but any advice is appreciated. 

    Here is the html markup below .aspx. Thanks!

    <table width="100%">
        <tr>
            <td style="width:100%;" align="center">
                 <asp:UpdatePanel ID="UpdatePanel1" runat="server" UpdateMode="Conditional">            
                 <ContentTemplate>    
                        <asp:LoginView ID="LoginView1" runat="server">
                            <AnonymousTemplate>
                                <asp:Button ID="Button3" runat="server" PostBackUrl="~/Account/Login.aspx" Text="Login" />
                            </AnonymousTemplate>
    						<RoleGroups>
                            <asp:RoleGroup Roles="Admin">
                                <ContentTemplate>                                                                                                         
                                <table width="100%">
                                <tr>
                                <td style="width:75%; vertical-align:top;" align="center">
                                <table width="100%">                                                    
                                <tr>                                                                    
                                    <td style="width:10%;">
    
                                    </td>
                                    <td style="width:80%;" align="center">
                                        <asp:Panel ID="Panel1" runat="server" CssClass="stepsHeader">
                                        <asp:Label ID="Label1" Font-Size="Large" Font-Bold="true" ForeColor="#7D7B03" runat="server" />
                                        </asp:Panel>
                                        <asp:Panel ID="Panel2" runat="server" CssClass="stepsBody">                                       
                                            <table width="100%"> 
                                            <tr>
                                                <td style="width:100%;" align="center">
                                                    <asp:Label ID="Label31" runat="server" ForeColor="Black" Text="<p style=&quot;color:#7D7B03; font-weight:bold;&quot; align=&quot;center&quot;> To Enter A WOD Entry</p>"></asp:Label>
                                                </td>
                                            </tr> 
                                            <tr>
                                                 <td align="center">
                                                      <table>
                                                      <tr>
                                                           <td align="center">
                                                                  <asp:RadioButton ID="rbToday" runat="server" style="color:white;" GroupName="WOD_Entry_Day" Text="Today" Checked="True" OnCheckedChanged="rbWOD_Entry_Day_Today_CheckedChanged" AutoPostBack="True" Visible="True" />                
    															  <asp:RadioButton ID="rbTomorrow" runat="server" style="color:white;" GroupName="WOD_Entry_Day" Text="Tomorrow" Checked="False" AutoPostBack="true" OnCheckedChanged="rbWOD_Entry_Day_Tomorrow_CheckedChanged" Visible="True" />
                                                           </td>                                                       
                                                      </tr>
                                                      <tr>
                                                           <td align="center">
                                                                <asp:UpdatePanel ID="UpdatePanel_WODDate" runat="server">                                                                                         
                                                                   <ContentTemplate>                                                                  
                                                                     <fieldset>
                                                                     <legend><font style="color:white;">
                                                                          <p>
                                                                               WOD Date 
                                                                          </p>
                                                                       </font> 
                                                                     </legend>
                                                                     <table>
                                                                     <tr>
                                                                          <td align="center">
                                                                               <asp:Label ID="lblDay" runat="server" ForeColor="White" Text="Test" Visible="true"></asp:Label>
    
                                                                          </td>
                                                                     </tr>
                                                                     </table>
                                                                     <table>
                                                                     <tr>
                                                                          <td>
                                                                               <asp:ImageButton ID="btnLeftClick" runat="server" Text="" ImageUrl="~/Images/leftArrow.png" onclick="btnLeftClick_WOD_Scroll" Enabled="true" />
                                                                          </td>
                                                                          <td align="center">
                                                                               <asp:Label ID="lblTomorrow" runat="server" ForeColor="White" Text="Test"></asp:Label>
                                                                          </td>
                                                                          <td>
                                                                               <asp:ImageButton ID="btnRightClick" runat="server" Text="" ImageUrl="~/Images/rightArrow.png" onclick="btnRightClick_WOD_Scroll" Enabled="true" />
                                                                          </td>
                                                                     </tr>
                                                                     </table>
                                                                     </fieldset>
                                                                   </ContentTemplate>
                                                                </asp:UpdatePanel>
                                                                <asp:UpdateProgress ID="UpdateProgress1" runat="server">
                                                                   <ProgressTemplate>
                                                                      <font style="color:Gold;"> Processing... </font>
                                                                   </ProgressTemplate>
                                                                </asp:UpdateProgress>                                                            
    														</td>                                                       
                                                      </tr>
                                                      </table>
                                                 </td>
                                            </tr>                                      
                                            <tr>

    Thursday, November 27, 2014 9:36 PM

Answers

  • User-271186128 posted

    Hi chjones2008,


    The functionality works in Safari, Firefox and IE. but the Async Postback doesn't work in chrome (production).  In my development environment the Async Postback works in Chrome but on production server it doesn't work.  

    From your description the Async Postback works well in your development environment, but it doesn't worked on the production server. So, I suppose the issue is related to the version of chrome browser. Please check it and use the latest version.

    Best Regards,
    Dillion

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, November 29, 2014 2:31 AM
  • User-271186128 posted

    Hi chjones2008,


    My Google Chrome is up to date.

    If that is the case, I suppose perhaps it is related to the Chrome browser settings. This is outside of the scope of this forum. So, I suggest you posting your question to Chrome forum. You will get more professional answers in there.

    The following is the Chrome forum address: https://productforums.google.com/forum/#!categories/chrome

    Best Regards,
    Dillion

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 2, 2014 1:18 AM

All replies

  • User-271186128 posted

    Hi chjones2008,


    The functionality works in Safari, Firefox and IE. but the Async Postback doesn't work in chrome (production).  In my development environment the Async Postback works in Chrome but on production server it doesn't work.  

    From your description the Async Postback works well in your development environment, but it doesn't worked on the production server. So, I suppose the issue is related to the version of chrome browser. Please check it and use the latest version.

    Best Regards,
    Dillion

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, November 29, 2014 2:31 AM
  • User-1835835255 posted

    My Google Chrome is up to date.

    Sunday, November 30, 2014 7:34 PM
  • User-271186128 posted

    Hi chjones2008,


    My Google Chrome is up to date.

    If that is the case, I suppose perhaps it is related to the Chrome browser settings. This is outside of the scope of this forum. So, I suggest you posting your question to Chrome forum. You will get more professional answers in there.

    The following is the Chrome forum address: https://productforums.google.com/forum/#!categories/chrome

    Best Regards,
    Dillion

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 2, 2014 1:18 AM
  • User39490543 posted

    Further questions -- is this a problem for multiple users with Chrome, or just one user? And, please clarify what you mean by "doesn't work"? And, have you tried debugging this through the Chrome DevTools? (see e.g. Debugging JavaScript)

    Wednesday, December 17, 2014 4:09 PM
  • User-1835835255 posted

    This is a problem for multiple users of chrome I've tried it on many computers with chrome and it doesn't work. When I say it doesn't work I mean I press the radio button and nothing happens. As you can see from my code above it has an update progress on that
    action and it doesn't fire and my end result doesn't finish. This only is a problem in chrome. And no I haven't tried debugging with the dev tools.
    Thursday, December 18, 2014 12:56 AM
  • User-1835835255 posted

    now it works for some reason.

    Monday, December 29, 2014 9:23 AM
  • User-1835835255 posted

    I updated chrome browser on my phone and that fixed it too.

    Thanks

    Wednesday, January 7, 2015 1:03 PM