locked
.NET Framework - 3.5.1 won't activate - Error 0x800F081F

    Question

  • Hello,

    I have a question: Is the .NET Framework 3.5.1 supposed to work on the Windows Developer Preview? Because I can't activate it, I always get error 0x800F081F. I am using the 64-bit version on a VM.

    Dei Vadder


    Sunday, September 18, 2011 7:48 PM

Answers

  • You get the message that the source fiels are missing (CBS_E_SOURCE_MISSING). So try this instead:

     

    1.       Copy \sources\sxs\ from the mounted operating system build ISO image to dotnet35 or similar folder. For example:

    xcopy e:\sources\sxs\*.* c:\dotnet35 /s

    2.       Execute the following command line using admin privileges:

    Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:c:\dotnet35 /LimitAccess

     


    "A programmer is just a tool which converts caffeine into code"

    Monday, September 26, 2011 7:49 PM

All replies

  • It installed without issue.

     

    See this thread, it may depend on how you install it:

    http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/3e5f065e-fe5a-4c56-9e98-d42c6b47e7f7

     

    Sunday, September 18, 2011 8:03 PM
  • .NET 3.5 might fail because it is not supposed to be part of the Developer Preview as stated in https://blogs.msdn.com/b/b8/archive/2011/09/02/reflecting-on-our-first-conversations-part-2.aspx

    So it's not part of the Dev. Preview?
    Monday, September 19, 2011 2:12 PM
  • It should work on it.
    It's not enabled by standard though.

    Look at the link TrekDozer put in his comment, that should solve your problem.

    Regards,

    Dylan Meeus


    0x2B |~ 0x2B Blog : www.it-ca.net/blogdylan
    Monday, September 19, 2011 2:17 PM
  • Look at the link TrekDozer put in his comment, that should solve your problem.
    That's what I did. Didn't solve my problem.
    Monday, September 19, 2011 4:52 PM
  • .Net Framework 3.5.1 is installed in the Windows Developer Preview but it is not enabled by default.
    Go to Start button, Control panel, More settings, Programs, Add or remove Windows features.
    Put a check next to .Net Framework 3.5.1 to enable it.

    Most programs that need .Net Framework 3.5.1 will prompt for you to install it.
    Marilyn
    Monday, September 26, 2011 3:01 AM
    Moderator
  • You get the message that the source fiels are missing (CBS_E_SOURCE_MISSING). So try this instead:

     

    1.       Copy \sources\sxs\ from the mounted operating system build ISO image to dotnet35 or similar folder. For example:

    xcopy e:\sources\sxs\*.* c:\dotnet35 /s

    2.       Execute the following command line using admin privileges:

    Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:c:\dotnet35 /LimitAccess

     


    "A programmer is just a tool which converts caffeine into code"

    Monday, September 26, 2011 7:49 PM
  • It worked. Thanks for your answer.
    Saturday, October 01, 2011 7:02 PM