locked
Azure Stack TP3 error index=60.61 RRS feed

  • Question

  • Hi,

    I have got this error every time I try to deploy the azure stack tp3. Please suggest me what is missing. Thanks a lot.



    YanAung


    • Edited by YanAung Tuesday, April 4, 2017 2:38 AM
    Tuesday, April 4, 2017 2:37 AM

Answers

  • Hello,

    In analyzing your logs I noticed a Time synchronization issue cause the deployment to fail at 60.61.101

     

    From your logs

    'SQL:Deployment' in module 'Classes\SQL\SQL.psm1' raised an exception: WinRM cannot process the request. The following error with errorcode 0x80090324 occurred while using Negotiate authentication: There is a time and/or date difference between the client and server

     

    To fix

    Run the following script from an elevated PowerShell session  on the DVM Host as AzureStackAdmin if deployment fails due to a time sync issue.

    NOTE: During deployment, after the Host reboots, the DC (MAS-DC01) syncs with time.windows.com and then the Host and all other VMs sync to the DC.

     

    ### Create array of VMs

    $ALLVMS = @("MAS-ACS01","MAS-ADFS01","MAS-Sql01","MAS-BGPNAT01","MAS-CA01","MAS-Con01","MAS-Gwy01","MAS-NC01", "MAS-SLB01", "MAS-SUS01", "MAS-WAS01", "MAS-Xrp01")

    # Compare server time between Host and VMs

    Invoke-command -Computername $ALLVMS -ScriptBlock {Get-Date}

    Get-Date

    # Sync MAS-DC01 to time server time.windows.com

    W32tm /resync /Computer:MAS-DC01 /nowait

    # Syncs all VMs with MAS-DC01

    Invoke-Command -Computer $ALLVMS -ScriptBlock { gsv w32time | sasv; w32tm /resync /force }

    # Syncs Host with MAS-DC01

    Invoke-Command -Computer $env:Computername -ScriptBlock { gsv w32time | sasv; w32tm /resync /force }

    # Compare server time between Host and VMs

    Invoke-command -Computername $ALLVMS -ScriptBlock {Get-Date}

    Get-Date

      

    Once the time is synced between all Server VMs redeploy using the -rerun parameter

    NOTE: Make sure you are running the deployment as under the AzureStack\AzureStackAdmin account.

      

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

       

    If that does get you past 60.61 then please confirm that the host machine has a D drive? 

    Typically if you are booting from VHD the VHD becomes the C drive and the underlying drive hosting the VHD becomes D.  The join path error is trying to create a path from where it is executing, not the target.  If the host machine does not have a D drive or that is assigned to an CD/DVD with nothing inserted then this may be causing the issue.  You can try changing drive assignments on the host such that there is a volume mounted to D.  Note that the full path does not have to be there, it is constructing the path and PowerShell simply needs a volume mounted on D.  This is something that will be addressed in later releases.

      

    If this does not apply, then please try to Redeploy Azure Stack TP3 using the following command:

      

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

      

    Also - Azure Stack requires access to the Internet either directly or through a transparent proxy.

    Public IP's are not required by Azure Stack TP3. 2 private NAT IP addresses assigned via DHCP or statically are all that is required.

      

    Both the host IP and the new IP assigned to the MAS-BGPNAT01 (by DHCP or static IP) must be able to access Internet. Ports 80 and 443 are used under the graph.windows.net and login.windows.net domains.

     

    Azure Stack TP3 does not support Web Proxy for Internet access.

    Make sure to disable ALL but one network adapter.

      

    If your environment DOESN'T have DHCP enabled

    You must include the following parameters to you deploy command to assign an IP to the MAS-BGPNAT gateway:

     

    .\InstallAzureStackPOC.ps1 -AdminPassword $adminpass -AADAdminCredential $aadcred

    -NatIPv4Subnet 10.10.10.0/24 -NatIPv4Address 10.10.10.3 -NatIPv4DefaultGateway 10.10.10.1

     

    If DNS resolution seems to be the issue:

    -          Use the optional -EnvironmentDNS setup parameter to add an external DNS server. 

    A DNS server is created as part of the Azure Stack deployment. To allow computers inside the solution to resolve names outside of the stamp, provide your existing infrastructure DNS server or a reliable known public DNS Server IP. The in-stamp DNS server forwards unknown name resolution requests to this server.

     

    Once network settings have been verified please redeploy with the command below:

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

     

    NOTE: Make sure you are running the deployment as under the AzureStack\AzureStackAdmin account.

     

    If you continue to receive error at step 60.61:

    Reboot the Host and MAS-Gwy01 VM.

    Make sure all VM roles are up by checking the roles in 'Failover Cluster Manager'

    Redeploy with the command below:

     

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

     

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with TP3 release, feel free to contact us.

    TP3 Azure Stack Docs:

    https://docs.microsoft.com/en-us/azure/azure-stack/

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-troubleshooting

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-diagnostics

    https://aka.ms/GetAzureStackLogs

     

    Thanks,


    Gary Gallanes

    Tuesday, April 4, 2017 8:19 PM

All replies

  • Ensure internet connectivity on your Host and MAS-BGPNAT01 VM  and rerun the script.

    cd C:\CloudDeployment\setup
    .\InstallAzureStackPOC.ps1 -rerun


    Cheers,

    Ruud
    Twitter:    Blog: AzureStack.Blog  LinkedIn:    
    Note: Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Tuesday, April 4, 2017 1:18 PM
  • Hello,

    In analyzing your logs I noticed a Time synchronization issue cause the deployment to fail at 60.61.101

     

    From your logs

    'SQL:Deployment' in module 'Classes\SQL\SQL.psm1' raised an exception: WinRM cannot process the request. The following error with errorcode 0x80090324 occurred while using Negotiate authentication: There is a time and/or date difference between the client and server

     

    To fix

    Run the following script from an elevated PowerShell session  on the DVM Host as AzureStackAdmin if deployment fails due to a time sync issue.

    NOTE: During deployment, after the Host reboots, the DC (MAS-DC01) syncs with time.windows.com and then the Host and all other VMs sync to the DC.

     

    ### Create array of VMs

    $ALLVMS = @("MAS-ACS01","MAS-ADFS01","MAS-Sql01","MAS-BGPNAT01","MAS-CA01","MAS-Con01","MAS-Gwy01","MAS-NC01", "MAS-SLB01", "MAS-SUS01", "MAS-WAS01", "MAS-Xrp01")

    # Compare server time between Host and VMs

    Invoke-command -Computername $ALLVMS -ScriptBlock {Get-Date}

    Get-Date

    # Sync MAS-DC01 to time server time.windows.com

    W32tm /resync /Computer:MAS-DC01 /nowait

    # Syncs all VMs with MAS-DC01

    Invoke-Command -Computer $ALLVMS -ScriptBlock { gsv w32time | sasv; w32tm /resync /force }

    # Syncs Host with MAS-DC01

    Invoke-Command -Computer $env:Computername -ScriptBlock { gsv w32time | sasv; w32tm /resync /force }

    # Compare server time between Host and VMs

    Invoke-command -Computername $ALLVMS -ScriptBlock {Get-Date}

    Get-Date

      

    Once the time is synced between all Server VMs redeploy using the -rerun parameter

    NOTE: Make sure you are running the deployment as under the AzureStack\AzureStackAdmin account.

      

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

       

    If that does get you past 60.61 then please confirm that the host machine has a D drive? 

    Typically if you are booting from VHD the VHD becomes the C drive and the underlying drive hosting the VHD becomes D.  The join path error is trying to create a path from where it is executing, not the target.  If the host machine does not have a D drive or that is assigned to an CD/DVD with nothing inserted then this may be causing the issue.  You can try changing drive assignments on the host such that there is a volume mounted to D.  Note that the full path does not have to be there, it is constructing the path and PowerShell simply needs a volume mounted on D.  This is something that will be addressed in later releases.

      

    If this does not apply, then please try to Redeploy Azure Stack TP3 using the following command:

      

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

      

    Also - Azure Stack requires access to the Internet either directly or through a transparent proxy.

    Public IP's are not required by Azure Stack TP3. 2 private NAT IP addresses assigned via DHCP or statically are all that is required.

      

    Both the host IP and the new IP assigned to the MAS-BGPNAT01 (by DHCP or static IP) must be able to access Internet. Ports 80 and 443 are used under the graph.windows.net and login.windows.net domains.

     

    Azure Stack TP3 does not support Web Proxy for Internet access.

    Make sure to disable ALL but one network adapter.

      

    If your environment DOESN'T have DHCP enabled

    You must include the following parameters to you deploy command to assign an IP to the MAS-BGPNAT gateway:

     

    .\InstallAzureStackPOC.ps1 -AdminPassword $adminpass -AADAdminCredential $aadcred

    -NatIPv4Subnet 10.10.10.0/24 -NatIPv4Address 10.10.10.3 -NatIPv4DefaultGateway 10.10.10.1

     

    If DNS resolution seems to be the issue:

    -          Use the optional -EnvironmentDNS setup parameter to add an external DNS server. 

    A DNS server is created as part of the Azure Stack deployment. To allow computers inside the solution to resolve names outside of the stamp, provide your existing infrastructure DNS server or a reliable known public DNS Server IP. The in-stamp DNS server forwards unknown name resolution requests to this server.

     

    Once network settings have been verified please redeploy with the command below:

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

     

    NOTE: Make sure you are running the deployment as under the AzureStack\AzureStackAdmin account.

     

    If you continue to receive error at step 60.61:

    Reboot the Host and MAS-Gwy01 VM.

    Make sure all VM roles are up by checking the roles in 'Failover Cluster Manager'

    Redeploy with the command below:

     

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

     

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you continue experience any issues with TP3 release, feel free to contact us.

    TP3 Azure Stack Docs:

    https://docs.microsoft.com/en-us/azure/azure-stack/

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-troubleshooting

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-diagnostics

    https://aka.ms/GetAzureStackLogs

     

    Thanks,


    Gary Gallanes

    Tuesday, April 4, 2017 8:19 PM
  • Thanks a lot. I will try again and reply back.

    YanAung

    Wednesday, April 5, 2017 1:44 AM
  • I was able to deploy the azure stack after all. I did fresh deployment and got a time sync error at step 0.xx. Then, I login into MAS-DC01 and check the timezone (Default: PTS). Then I changed my physical host time zone to PTS and did a rerun. Now it is successfully running. One thing I like to ask is Can I change the PST time zone to Singapore Time Zone now?

    Thanks.


    YanAung

    Thursday, April 6, 2017 2:34 AM
  • Great feedback YanAung.

    Cheers,

    Ruud
    Twitter:    Blog: AzureStack.Blog  LinkedIn:    
    Note: Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, April 6, 2017 12:50 PM