none
Installation of Application server with .NET 3.5.1 fails on Windows server 2008R2 RRS feed

  • Question

  • Hi,

    I'm using Windows server 2008 R2 SP1 standard edition.

    I'm trying to install Application server with only the .NET framework 3.5.1 role service. At first I tried to use the MMC, but the MMC fails.
     
    At first I uninstalled .NET framework 4.0, witch was already installed on the server because I thought it might cause a conflict.
     
    Then I tried to use Powershell (with the ServerManager module). With the -whatIf parameter the 'installation result' was a success, but when I tried to acctually run the installation it fails with a fatal error as a result.
     
    "failed with error code 0x80070643. Fatal error during installation At line:1 char:19 + Add-WindowsFeature <<<< AS-NET-Framework"

    I created a similar thread in the "General" forum, but they asked me to create a thread here instead. Link to the first thread: http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/f69967b5-8ad3-4cde-8c29-a72e8e833f06

    Link to vslogs.cab: https://skydrive.live.com/?cid=615f104925dc2bc7#cid=615F104925DC2BC7&id=615F104925DC2BC7%21281

    MMC error message:

    Description:
     
    Stopped working
     Problem signature:

     Problem Event Name: CLR20r3
     
    Problem Signature 01: mmc.exe
     
    Problem Signature 02: 6.1.7600.16385
     
      Problem Signature 03: 4a5bc808
     
      Problem Signature 04: mscorlib
     
      Problem Signature 05: 2.0.0.0
     
      Problem Signature 06: 4e1539fa
     
      Problem Signature 07: 349e
     
      Problem Signature 08: 1f7
     
      Problem Signature 09: System.UnauthorizedAccess
     
      OS Version: 6.1.7601.2.1.0.16.7
     
      Locale ID: 1053

    I'd be thankful if anyone could answer the question. Sorry if this question has already been answered in another thread (and sorry for my bad english :p ).

    //Marcus Andersson

    Monday, April 23, 2012 12:11 PM

Answers

  • Hi MarcusAn,

    Sorry for late track.

    But from your decription, I would suggest you reinstall your OS. .NET 3.5 as a feature of your OS is corrupt and cannot be enabled.

    Thanks for understanding.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, May 3, 2012 7:01 AM
    Moderator

All replies

  • I'm a bit surprised you were sent here, but we can at least verify your .NET Frameworks in your WS 2008 R2.

    Please run this .NET Framework Verification Tool, with .NET Framework 3.5 selected:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Post the first 15 lines and last 15 lines of tool output here.

    Monday, April 23, 2012 3:08 PM
  • When I had installed the same in multiple severs, it worked fine. Let's see the output of the .net verification tool provided in other reply.

    Gangadhar Kotu, MCTS SharePoint 2010

    Monday, April 23, 2012 3:26 PM
  • Hi MarcusAn,

    Thanks for your post.

    If your error is because .NET 3.5 installation error. I think first we can try to verify .NET 3.5 as pvdg42 mentioned. So could you please have a look at this blog?

    http://blogs.msdn.com/b/sqlblog/archive/2010/01/08/how-to-install-net-framework-3-5-sp1-on-windows-server-2008-r2-environments.aspx

    You will find"How to verify if .NET Framework 3.5 SP1 is installed" and "If .NET Framework 3.5.1 feature is not listed, you can use either of the following methods to install it " on that page

    Actually, collect tool will only collect the installation logs of Visual Studio and .NET Framework but not your application server. I have checked your logs and didn't find any installation logs of .NET Framework. So please show us the result of the .NET verification.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us


    Tuesday, April 24, 2012 5:59 AM
    Moderator
  • Thank you everybody for the answers.

    I checked out your link Barry Wang, and the .NET Framework 3.5.1 is not listed in the Features 'view' of server Manager. When I try to add it with methon 1 "Using Server Manager Interface" the mmc hangs up, and when I try to install (with methoedd 2) as-net-framework with Powershell i get a "fatal error". That's acctually the reason why i started the first thread :-(

    When I run the .NET framework setup verification utility, I can only choose .NET framework 2.0SP2 .NET Framework 4 client .NET Framework 4 Full. Guess that's the versions the app detects, as Aaron Stebner writes in http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx "verification tool will only list versions of the .NET Framework that it detects are installed ".

    After that i used it using cmd netfx_setupverifier.exe /q:a /c:"setupverifier.exe /a" to be able to choose other versions and collected the results of more versions than the ones first listed, and copied the log into different .txt files, named them after the version i tried to verify, and uploaded them to Skydrive. The these files are avalible here: https://skydrive.live.com/?cid=615f104925dc2bc7#cid=615F104925DC2BC7&id=615F104925DC2BC7%21281

    Wednesday, April 25, 2012 11:50 AM
  • Hi MarcusAn,

    Sorry for late track.

    But from your decription, I would suggest you reinstall your OS. .NET 3.5 as a feature of your OS is corrupt and cannot be enabled.

    Thanks for understanding.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, May 3, 2012 7:01 AM
    Moderator
  • Thank you for the answer. =)
    Wednesday, May 16, 2012 9:21 AM