none
Error In Vista RRS feed

  • General discussion

  • Hi All,
    I'd created a window based application and it works fine on windows XP proffessional, but when I'm going to install this application on windows vista setup runs smoothly but application will not able to open. Please suggest me the approprate solution for this problem. Thanks in advance.



    Virender Singh Balouria
    • Changed type YiChun Chen Friday, August 7, 2009 2:43 AM Do not follow up
    Friday, July 31, 2009 5:19 AM

All replies

  • Could you provide more information, like if there is any error message or what exactly happen? Could you try this example but with tiny program like hello world and try to deploy it to vista and XP and post the result.

     

     

     


    We are volunteers, if the reply help you mark it as your answer. thanks!!
    My Blog
    Saturday, August 1, 2009 5:09 PM
  • Hi Virender,

    Could you please clarify your issue more? How do you deploy your application? Did you receive any error message during the installation?

    Thanks


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 3, 2009 8:42 AM
  • Hi Chen,
    I'd created a windows application in .net framework 2.0 in which I'm using MS word, Excel and xml also. when I created a setup for this application and simple runs on windows XP professional it works fine, but when I'm installing the same setup Windows Vista Home Machine it first throws an error that "Module 'MSXML4.dll' failed to register" while installation of setup, but when I run setup for MSXML downloaded from Microsoft's site, setup of my application runs smoothly. Now when I'm going to open that application after installation then only one message appears as "Editor currently stops working".I also create a simple Hello
    World program to check this, and my Hello World program works fine.
    Please help me to sort out this problem or suggest me that what I'm doing wrong.
    Thanks in advance.


    Virender Singh
    Tuesday, August 4, 2009 4:40 AM
  • Hi Virender,

    Thank you for your detail information.

    Did you receive the error message like the following?

    Error 1904. Module C:\Windows\System32\msxml4.dll failed to register. HRESULT -2147024891.

    I'd created a windows application in .net framework 2.0 in which I'm using MS word, Excel and xml also.
     ......

    I also create a simple Hello
    World program to check this, and my Hello World program works fine.

    Based on your description, the error message is related to Microsoft XML Core Services (MSXML) 4.0. I suspect that it could be related to corrupted Microsoft XML Core Services (MSXML) 4.0 on your Vista machine.
    Have you tried other Vista machine to install your application? Will this situation occur?

    Please try to download and then install the latest service pack release of Microsoft XML Core Services (MSXML) 4.0. Please also try this update: http://support.microsoft.com/kb/941833

    Thanks

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Tuesday, August 4, 2009 6:17 AM typo
    Tuesday, August 4, 2009 6:14 AM
  • Hi Virender,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, August 7, 2009 2:43 AM