none
Visual Studio 2013: Compiling to x86? RRS feed

  • Question

  • I'm starting a new project with Bing Maps SDK in Visual Studio 2013. I know that I have to change the platform for a specific processor - All Platforms won't compile with the Bing Maps SDK.

    Right click project -> Properties -> Debug tab -> Platform -> x86 (or x64)

    When I build, the output windows says Configuration: Debug Any CPU. When I reopen the Properties -> Debug tab, it says Active (Any CPU), so apparently, my setting is ignored/not saved.

    Since I cannot do anything with Bing Maps until this is resolved, I'm hoping someone else has this sorted out.


    Randy

    Wednesday, November 20, 2013 7:14 PM

Answers

  • Just to add to david's response you can set the active platform in the configuration manager by selecting the Build button on the main menu, then go to Configuration manager, in the window that opens you will see a platform dorp down that ill have Any CPU, x86, x64, and ARM. On the Any CPU setting look at the apps that are listed and in the platform column change any CPU to x86. This is documented here: http://msdn.microsoft.com/en-us/library/dn456475.aspx

    When it comes to building the package for the windows store you will have to compile against each platform separately. This adds a couple extra minutes in the deployment process but is required whenever your .NET project uses the Microsoft C++ runtime.


    http://rbrundritt.wordpress.com

    Wednesday, November 20, 2013 7:43 PM
  • The Platform Target is on the Build tab, not the Debug tab.  And you are setting the Platform Target for the active Solution Configuration and Solution Platform. 

    By default you have only one Solution Platform.  It is called "Any CPU" but it does not control the "Platform Target" settings of individual projects.  You can set the Platform Target of your project to x86, even if the active Solution Platform is called "Any CPU".

    David


    David http://blogs.msdn.com/b/dbrowne/


    Wednesday, November 20, 2013 7:23 PM

All replies

  • Sorry for the noise. I should have dug a little more. Setting x86 in the Build -> Configuration Manager -> Active solution platform dropdown works.

    Hope this helps someone else....


    Randy

    Wednesday, November 20, 2013 7:17 PM
  • The Platform Target is on the Build tab, not the Debug tab.  And you are setting the Platform Target for the active Solution Configuration and Solution Platform. 

    By default you have only one Solution Platform.  It is called "Any CPU" but it does not control the "Platform Target" settings of individual projects.  You can set the Platform Target of your project to x86, even if the active Solution Platform is called "Any CPU".

    David


    David http://blogs.msdn.com/b/dbrowne/


    Wednesday, November 20, 2013 7:23 PM
  • Just to add to david's response you can set the active platform in the configuration manager by selecting the Build button on the main menu, then go to Configuration manager, in the window that opens you will see a platform dorp down that ill have Any CPU, x86, x64, and ARM. On the Any CPU setting look at the apps that are listed and in the platform column change any CPU to x86. This is documented here: http://msdn.microsoft.com/en-us/library/dn456475.aspx

    When it comes to building the package for the windows store you will have to compile against each platform separately. This adds a couple extra minutes in the deployment process but is required whenever your .NET project uses the Microsoft C++ runtime.


    http://rbrundritt.wordpress.com

    Wednesday, November 20, 2013 7:43 PM