none
WEC 7 Image was built for Chinese UI but names are still displayed in English characters RRS feed

  • Question

  • We have added the Simsun fonts to our image and we did see the chinese name of this font our program checks for available fonts. However, the Simsun font name (in English characters) are still being displayed which sort of is a duplicate to the already chinese name. Do we need to add any specific registry to fix this? Or what other settings have we possibley missed?
    Wednesday, January 14, 2015 6:43 AM

Answers

  • Try setting the registry 

    Simplified Chinese GB18030 Text Converter Registry Settings

    https://msdn.microsoft.com/en-us/library/ee491329(v=winembedded.70).aspx

    • Marked as answer by MJ Masbad Monday, March 23, 2015 8:40 AM
    Wednesday, February 11, 2015 5:41 AM

All replies

  • Hello MJ Masbad

    Have you selected Chinese fonts from the catalog items. If not then please select it from here: -

    Core OS->Windows Embedded Compact ->Fonts ->Scripts ->Chinese

    Wednesday, January 14, 2015 6:53 AM
  • Yup. We have already done this
    Wednesday, January 14, 2015 8:05 AM
  • Right now, we are already able to get the folder names in chinese character.

    However, the font names displayed (say open Word pad and change font) is still in english. For example it shows Simsun instead of the chinese character of Simsun.

    Any suggestion what I missed here?

    Wednesday, February 11, 2015 2:48 AM
  • Try setting the registry 

    Simplified Chinese GB18030 Text Converter Registry Settings

    https://msdn.microsoft.com/en-us/library/ee491329(v=winembedded.70).aspx

    • Marked as answer by MJ Masbad Monday, March 23, 2015 8:40 AM
    Wednesday, February 11, 2015 5:41 AM
  • Did you set the Locale to be one of the Chinese options?

    Bruce Eitman (eMVP) Senior Engineer Bruce.Eitman AT Eurotech DOT com My BLOG http://geekswithblogs.net/bruceeitman Eurotech Inc. www.Eurotech.com

    Wednesday, February 11, 2015 2:09 PM
    Moderator
  • I did set this but it seems our legacy design (running CE 5.0) have sort of customized implementation implementation of localization. I'm only comparing our CE 7 and the CE 5.0 binaries right now and seems like there is one registry that I can't seem to enable in CE 7.0 even if I override in OSDesign.reg. This is

    [HKEY_LOCAL_MACHINE\nls]
        "DefaultLCID"=dword:804

    There are a couple of location for this DefaultLCID entry one on Boot registry the other inside the main registry. Is this registry still being supported in CE 7? Coz I can't find any clear documentation describing this in CE 7 and only in CE 5.0

    Tuesday, February 24, 2015 10:28 AM
  • Supported as per following link

    https://msdn.microsoft.com/en-us/library/ee491153%28v=winembedded.70%29.aspx?f=255&MSPPError=-2147217396

    Tuesday, February 24, 2015 10:40 AM