locked
Cannot start test project 'TestOfTest' because the project does not contain any tests RRS feed

  • Question

  • Hi.

    I'm having an issue with the unit testing in Visual Studio 2010.

    I can not run unittests on solutions that reside on a network drive.

    Creating a C++ test project on my local C-drive creates a test that runs nicely.

    Creating the same C++ test project on a network drive creates a test that does not run and gives the error message: Cannot start test project 'TestOfTest' because the project does not contain any tests

    The only difference is the location of the project.

    Now due to company policy projects are required to run from the network drive. So how do I make the test project run form the network drive?

    Thanks in advance

       John.

    • Moved by Jesse Jiang Tuesday, August 30, 2011 5:47 AM (From:Visual C++ General)
    Monday, August 29, 2011 8:49 PM

Answers

All replies

  • Hi John,

     

    I think your issue should be raised in the Visual Studio Unit Testing. I believe they will know more information of this issue than us, and I will move this one to that forum.

     

    Thanks for your understanding,

     

    Best regards,

    Jesse


    Jesse Jiang [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, August 30, 2011 5:46 AM
  • Can you try this workaround listed here http://connect.microsoft.com/VisualStudio/feedback/details/502353/running-unit-tests-from-network-drive

    "The workaround is to set COMPLUS_LoadFromRemoteSources=1"

    Open a command prompt and type "setx COMPLUS_LoadFromRemoteSources 1"
    or
    Create an environment variable named COMPLUS_LoadFromRemoteSources
    Set the value to 1

    Restart Studio


    http://www.anujchaudhary.com/
    Tuesday, August 30, 2011 6:47 AM
  • Yes. Thank you very much. That works.
    Tuesday, August 30, 2011 8:18 AM
  • Hi Anuj,

    After tried running test from remote location, my location test also stopped running with an error message "Cannot start test project 'xyz' because the project does not contain any tests". I've got stuck up and even scripts in local machine are not running. Can u help me?

    Wednesday, December 5, 2012 2:58 PM