none
Web Hooks Stopped Working

    Question

  • I have a basic TFS webhook that fires when a work item changes.  This webhook has been in place for years and then yesterday it stopped working and I have no idea why.  There's no record of any requests (looking at the service hook call history), it's as if the work item change isn't firing the event.  I know the webhook is configured correctly, because running a "Test" of the service hook trigger does contact my webapi correctly.

    How are work item events fired?  Where do I see how a work item is wired up to fire an event?  Is there a log file somewhere that would possibly show me why these requests aren't firing?


    Thursday, April 20, 2017 4:45 PM

All replies

  • Hi P. Scott Ramuno,

    Please go to your TFS server, check whether TFSJobAgent service is running:

    If it is not running, TFS will not send message to Webhooks. After you start it, all the requests during the TFSJobAgent stop time will be sent.

    Best Regards


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 21, 2017 7:59 AM
  • Thank you very much.  That solved it.

    In all the service hook information that's provided online for TFS, there's not any mention of this service.

    Friday, April 21, 2017 2:11 PM