locked
List ordering RRS feed

  • Question

  • I have a list that is not reflecting the correct ordering on the main page.  The list appears in the correct order if I pop open the list, but not from the main page.  How can I fix this?

    Thursday, September 26, 2013 9:27 PM

All replies

  • Hi,

    Are you talking about the ordering of the items on the list view?

    Then, you might be opening a different view in the pop up and some other view in the main page.

    In order to fix the ordering on the main page, open the Library tab in your Ribbon then select the modify view option. Go to the ordering option in the page, select the necessary ordering and everything should be fine after this.

    Regards,

    Sharath


    sharath kumart shivarama

    Friday, September 27, 2013 1:21 AM
  • Yes.  I'm referring to the ordering of the list items.  The items within the list appear in proper order.  From the main page, they are not appearing in the proper order.  I've tried modifying the sort order on the list, but that doesn't change how it appears on the main page.  I thought perhaps it required modifying the web part??? 

    I do think it has to do with the view.  When I tried Editing the Page and selecting the appropriate view, it does put it in the right order, but it also exposes the "Edit" icon and "Sort order" column that is only visible from inside the list.  I don't want that to appear on the main page.

    Any ideas?

    Thanks,

    Sydney

    Monday, September 30, 2013 3:50 PM
  • You need to put sorting on the main page where you have added this list by modifying the list web part settings. Or remove and add the list webpart again on the same page.
    Monday, September 30, 2013 10:51 PM
  • Please advise how to put sorting on the main page.  Where are the list web part settings?

    I just tried removing/adding the web part.  It didn't work.

    Thanks,

    Sydney

    Monday, September 30, 2013 11:10 PM
  • If you Edit your page you will be able to find the web part settings icon at right top corner on the webpart. Using the same icon click on edit webpart -> edit current view.
    Monday, September 30, 2013 11:14 PM
  • I just tried editing the sort order from the main page on the current view.  The sort options are not editable from the main page (grayed out if that makes sense).  Any ideas?
    Tuesday, October 1, 2013 5:43 PM
  • Are you having proper permissions on List or you having only read only? If that is not the case, something else is wrong.

    Well if you are able to select the view on the settings, create a new view where you can uncheck "Edit" and "Sort Order" columns, and use the same newly created view in your main page.

    Try it and let me know.

    Tuesday, October 1, 2013 7:37 PM
  • Yes I am an administrator so I have full control.

    I tried creating a new view and unchecking edit and sort order.  It didn't work.

    Thanks,

    sydney

    Wednesday, October 2, 2013 6:12 PM
  • Can you try https://join.me/ or any other application to share your screen, I can help you out then.
    Wednesday, October 2, 2013 6:17 PM