locked
VS2012 Express for Windows unusable with freezing background process

    Question

  • Can anyone suggest how to fix this show-stopper problem? Not getting far in developing a Windows Store app.

    Version details are included at the end.

    Everything worked fine on starting a project and debugging a simple shell application with extended splash screen.

    Then I added a Grouped Grid View page from the template. Just compiled and ran and it worked OK (with no data source).

    Next I opened the template-generated XAML file for the grouped view page and the troubles started.

    First, the design view would not finish loading for the XAML file. But the app would still compile and run. Only problem was that VS2012 could not be shut down as it said it was waiting for a background process to complete and hung there on closing. It had to be killed from the task manager.

    Making the default editor for the XAML file be the source text editor and selecting the option to open an XAML file in source mode (to prevent the designer from coming up) does not prevent the above problem. There is still a background process that never completes. But the compile and debug worked.

    Then I started with adding some program logic to populate the GridView.

    Things got worse here. When I edited the initially generated grouped grid view page XAML file, I could not save it. It said some other process is using the file so I could only save it with a different name (looks like the background process that starts is hanging on to that file). So the only way to work now was to save the XAML file as another file after the edit, kill VS2012 from the task manager and then delete the original file and rename the edited file back to original and restart VS2012. Rebooting the machine does not help.

    This is not a viable solution for development, so I uninstalled VS2012 completely and re-installed the latest available (same version as earlier) and opened the same project. Same problem in that the background process starts and cannot exit from the program. But now when I tried to compile and debug, the test app which was running before just displayed the splash screen and brought the VS2012 window forward but there is no break in the debugger. VS2012 is completely unresponsive and frozen (no buttons or menus respond) and gives no indication of what the app is doing.

    Deleting the entire Blend sub-directory from the VS2012 directory does not prevent this problem either so it seems like the background process hanging happens even before Blend is started and possibly in trying to communicate with Blend. Just a guess here not knowing how things work in VS2012.

    So, we are not sure how to proceed with the project to develop an app for Windows 8 without workable tools and have had to put the project on hold.

    Is there anything I can try doing to fix this or should we wait for the next update and hope the problem is fixed?

    Thanks

    Details:

    App was being developed in C++. Compiling and debugging for 32-bit.

    Running on Windows 8 Pro Release version with all Windows updates done. The machine is a fresh install with no other software installed and used for clean development only. No firewalls or anti-virus running except Windows Defender. No repositories being used for this initial work.

    8GB of memory. Core i5 Sandy Bridge CPU 2.3MHZ. 120GB SSD.

    Microsoft Visual Studio Express 2012 for Windows 8
    Version 11.0.50727.1 RTMREL
    Microsoft .NET Framework
    Version 4.5.50709

    Installed Version: VSWin Express

    Team Explorer for Visual Studio 2012   04933-004-0021004-02823
    Microsoft Team Explorer for Visual Studio 2012

    Visual Basic 2012   04933-004-0021004-02823
    Microsoft Visual Basic 2012

    Visual C# 2012   04933-004-0021004-02823
    Microsoft Visual C# 2012

    Visual C++ 2012   04933-004-0021004-02823
    Microsoft Visual C++ 2012

    Visual Studio 2012 Code Analysis Spell Checker   04933-004-0021004-02823
    Microsoft® Visual Studio® 2012 Code Analysis Spell Checker

    ...

    NuGet Package Manager   2.1.31002.9028

    Tuesday, November 13, 2012 8:04 PM